Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've enabled SMB sharing in OS X Lion and have added folders to share, it says 'Windows Sharing: On' with a green circle next to it (from the sharing window) and that to access the volume I will need to to go to \\192.168.0.17.

It also says that the OS X should be visible as 'macbook' in the network.

Both my WIndows 7 and OS X are connected to the same network, yet when I try to go to \\192.168.0.17 or from the Mac try to go to my Windows system (smb://192.168.0.6) the two OSs don't see each other.

Any ideas why?

Attempting to ping the Mac from Windows results in this output in the command prompt:

Pinging 192.168.0.17 with 32 bytes of data:
Reply from 192.168.0.6: Destination host unreachable.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.0.17:
    Packets: Sent = 4, Received = 1, Lost = 3 (75% loss),

ipconfig in Windows is:

Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::8918:efd1:b05c:890f%21
   IPv4 Address. . . . . . . . . . . : 192.168.0.6
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.1

Ethernet adapter Bluetooth Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Ethernet adapter VMware Network Adapter VMnet1:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::98ab:63fc:3c07:d837%13
   IPv4 Address. . . . . . . . . . . : 192.168.74.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

Ethernet adapter VMware Network Adapter VMnet8:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::80ff:c575:7b50:3a10%14
   IPv4 Address. . . . . . . . . . . : 192.168.21.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

Tunnel adapter isatap.{2E97D0AE-9E18-4072-AC23-1979BA0DCB79}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter isatap.{E260CE43-E9A7-4DE0-A88E-4EAFF68ACDDB}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter isatap.{A5130812-59CE-4DDF-9C35-9433BCED9831}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter isatap.{134BCAE7-CFFF-4A98-8DA0-3708806AABEB}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter isatap.{8D9E3B8F-161C-4ACE-B211-3EDD694416B2}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

in OS X:

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    options=3<RXCSUM,TXCSUM>
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 
    inet 127.0.0.1 netmask 0xff000000 
    inet6 ::1 prefixlen 128 
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    options=2b<RXCSUM,TXCSUM,VLAN_HWTAGGING,TSO4>
    ether c8:2a:14:01:24:c1 
    media: autoselect (none)
    status: inactive
en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether e0:f8:47:0c:fe:04 
    inet6 fe80::e2f8:47ff:fe0c:fe04%en1 prefixlen 64 scopeid 0x5 
    inet 192.168.0.17 netmask 0xffffff00 broadcast 192.168.0.255
    media: autoselect
    status: active
p2p0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2304
    ether 02:f8:47:0c:fe:04 
    media: autoselect
    status: inactive
fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 4078
    lladdr 70:cd:60:ff:fe:d8:f1:32 
    media: autoselect <full-duplex>
    status: inactive
share|improve this question
    
I'd start by trying to ping each other from either side. Open up a command line in Windows and do ping 192.168.0.17 (assuming .17 is the Mac's IP). From OSX, open up a terminal and do ping 192.168.0.6. –  Banjer Jun 15 '12 at 12:51
    
yeah I tried that, no luck 'destination host unreachable' was the result when I tried that... –  meds Jun 15 '12 at 12:56
    
actually I might have done that wrong, in Windows I tried ping 192.168.0.17 which gave me that destination host unreachable error, when I tried using 'ping \\192.168.0.17' I got ping request could not find host \\192.168.0.17' –  meds Jun 15 '12 at 12:59
    
ping 192.168.0.17 without the backslashes is correct. –  Banjer Jun 15 '12 at 13:04
1  
I see no mention here of temporarily disabling your Windows Firewall for testing purposes, or opening up all the necessary port in your Firewall (137, 138, 139 and 445). Do you have an after-market firewall that came with an AV suite as well? No mention of turning on File and Printer sharing on the Windows Box. Sorry... can't assume you have done these things. –  Bon Gart Jun 15 '12 at 13:29
show 1 more comment

2 Answers

Ok figured out what the problem was!

I was following Banjer's advice and trying to see which clients were connected when I noticed that none of the PCs or phones attached were listed (despite the fact they had internet access).

Looking into it more I decided to do a hard reset on the device which solved that issue, and on top of that solved my connectivity issue.

So yes, it was very much a 'turn it off and on again' type thing.

share|improve this answer
add comment

Per my comment about ping test:

yeah I tried that, no luck 'destination host unreachable' was the result when I tried that...

Are both machines plugged into the same router or switch? Your network settings must be off. Please update your question with the output of ipconfig on Windows and the ifconfig command on OSX, and we'll see what you've got.

UPDATE

As @Bon Gart suggests, disable Windows firewall or any other software firewall completely for testing.

Log into your router and see what clients are connected in DHCP. Are the two IPs listed? That is, assuming your router is handling DHCP and you don't have some special setup.

Another good test is to disable your wireless adapters on each machine and try a regular wire connection instead of wireless, just to help rule out any wifi or wireless adapter issues.

share|improve this answer
    
ok I added the output details to the question, both computers are connected via wifi, I just tried renewing OSXs DHCP lease but that didn't help –  meds Jun 15 '12 at 13:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.