Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We need to disable hyperthreading on several MacPros.

We have just two types of Macs - Dual QuadCore 2.4 "Westmere" and single CPU SixCore 3.66 "Westmere". All machines run 10.6.8

For some strange reason the terminal command "sudo nvram SMT=0" works just fine on some dual-CPU machines and does not on others including all single-CPU machines. While checking NVRAM state all machines show this flag as set correctly, but some of them still show doubled number of cores in Activity Monitor.

All other means of disabling hyperthreading (Processor.prefpane, hwprefs, CHUD tools) have no effect at all.

I would greatly appreciate any clue on the issue.

share|improve this question
2  
Just disable it in the BIOS? –  Ramhound Jun 15 '12 at 16:39
    
What @Ramhound said, you should just do this in the BIOS. I am unfamiliar with Mac BIOS but it has to be in there somewhere. I do not think it's possible to DISABLE hyperthreading on the fly. –  Shinrai Jun 15 '12 at 16:43
    
... except Macs don't have a BIOS. Its Either the Open Firmware (cmd-opt-O-F) for older Macbook Pros, or for the newer Intel models, it's no access... since they use EFI. You could install rEFIt refit.sourceforge.net and access the pre-boot environment... but again, there IS no BIOS to disable things from. –  Bon Gart Jun 15 '12 at 17:25
    
Sorry... meant MacPro. had the typo thing going there –  Bon Gart Jun 16 '12 at 2:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.