Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Trac is a python-powered bug-tracking and project-management app. According to Trac's wiki, there are several options for installing Trac, a standalone server (tracd), or under a dedicated webserver using one of these options:

FastCGI - Not available on windows. mod_wsgi - No version of mod_wsgi available for Apache 2.2.22 and Python 2.7.3-amd64 that actually runs on my system! mod_python - no longer recommended, as mod_python is not actively maintained anymore) CGI -should not be used, as the performance is far from optimal)

That leaves me with zero ways to run Trac on Windows.

Apache 2.2.22 with ModWSGI loading, crashes the Apache2.2 service on startup without any error logs. Disabling the line in the apache configuration to load mod_wsgi restores sanity.

I just want an installation of Trac on windows with Authentication enabled. I am unable to get authenetication to work using basic tracd like this:

tracd -p 8000 --basic-auth="c:\tmp,c:\tmp\Passwords.md5.txt,mycompany" c:\tmp\RootFolder

And I am unable to get Mod_WSGI installed. I'm going to keep trying to figure out a combination that works, I suspect I should have installed 32 bit python instead of 64 bit python, to start with. Did I do wrong to install Python 64 bit 2.7.3? I tried again with all 32 bit components, and still can't get MOD_WSGI to work with apache 2.2.22. I'm going to try to compile mod_wsgi myself with Visual C++ Express 2010, but it seems to me that it ought to be easier than this to get Trac running on windows, with authentication.

Is there a way to run Trac on Windows, under Apache, with authentication?

The last "Trac on windows" article died in 2008, leaving only this internet archive link for "Trac on windows" setup.

Update the Bitnami installer looks promising, but it crashes on launch on Windows server 2008 R2. Workaround is to run with --mode win32 as command line parameters (use Run menu, or command prompt so you can run installer with parameters.)

share|improve this question
    
You need to determine if your current webserver is being ran as a 32-bit or 64-bit process. Once you do that you can install the correct library. You indicate you believe you made this mistake, you should determine if you did, before you came looking for assistance. –  Ramhound Jun 25 '12 at 13:23
    
Apache was 32 bit process. –  Warren P Jun 25 '12 at 14:20

1 Answer 1

up vote 2 down vote accepted

Use the Bitnami Stack Installer - you will have a working mod_wsgi when you are done. For us, it was very straightforward to modify the Bitnami installation for working with PostgreSQL and Windows domain authentication.

http://bitnami.org/stack/trac

share|improve this answer
    
Awesome. Except it crashes and dies on startup, in Windows Server 2008 R2. Something wrong with that installer. Download file URL: bitnami.org/download/files/stacks/trac/0.12.3-0/… –  Warren P Jun 22 '12 at 18:59
    
related: answers.bitnami.org/questions/5558/… –  Warren P Jun 22 '12 at 23:18
    
Windows Server 2008 R2 Workaround: Run installer with this command line parameter: --mode win32 –  Warren P Jun 25 '12 at 13:18
    
This just forces it to be a 32-bit process which indicates your entire webserver ( IIS ) is 32-bit process instead of 64-bit. A 64-bit process CANNOT load a 32-bit library. –  Ramhound Jun 25 '12 at 13:23
    
But I'm not using the IIS server at all. Apache is the HTTPD. –  Warren P Jun 25 '12 at 14:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.