Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying to resolve a website domain to localhost for development purposes. I am developing on a Wordpress Installation which has some inherent hardcoded redirects to the domain it is installed on. So I need to be able to resolve the domain it is for to my local environment to do development. I am on a windows machine using WAMP as my development server. I have added this line into my hosts file:

127.0.0.1        localhost
127.0.0.1        www.example.com

This works great when I visit www.example.com I get the expected WAMP application screen. The problem is when I try to visit the Wordpress Installation at www.example.com/blogs, this does not get resolved to my local environment, it takes me to the public facing site.

The strange thing is that this is not a problem on all computers I have it working on an XP and W7 computer. But it is also not working on two other W7 computers and some old computer I am unsure of OS for.

Can anyone provide some insight on what might be happening?

Update - Things that I have tried to avoid the possibility of caching: hard refreshing with Ctrl+F5, manually clearing the browser cache, using multiple browsers, clearing the dns cache with ipconfig /flushdns

share|improve this question

Sounds like you are getting a cached response. Have you tried Ctrl+F5 after browsing to www.example.com/blogs ?

share|improve this answer
    
Yes i have tried a hard refresh with Ctrl+F5, clearing the browser cache, using different browsers and flushing the dns from the command line. – Andy Jun 15 '12 at 18:49
    
Some ideas : Try looking at the http request in fiddler2 and verify that what you see happening is indeed happening. Also, are all or some of these machines on a domain? Is there any VPN's going on from these machines? What browser(s) are you seeing this behaviour in, is it all browsers on the affected machine? Are there any proxies configured? – Paul George Jun 15 '12 at 20:11
    
No VPN's, WAMP is being run locally on all of the laptops, the browser you check doesn't seem to matter, so all browsers. I looked into the possiblity of some interference from a Network Proxy but not finding anything wrong. – Andy Jun 18 '12 at 14:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .