Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've noticed that whenever I sign in in Google Chrome version 21.0 it automatically assumes and it automatically knows what I want to search. I basically use the address bar to search(my default search engine is Google) I don't go type Google.com on the address bar and then search from there. So what happens is that when I type something for example "vernier" for vernier caliper I'm automatically redirected to my facebook account which has a user account name of vern.ancheta.

It's really getting annoying, this happens for every search term that I used maybe even ones that I haven't used before in my entire search history in Google. It always assumes as if it knows what I'm really thinking. What's the solution for this? Is this a bug in Google Chrome or just one of its annoying features. Please enlighten me on this.

share|improve this question
    
Good inquiry. Wjat bugs me is I love using the typing of Yout and it automatically allows me to press Tab and I can search within the Omnibar. But sometimes, after a history clearing (I do this periodically), the Tab button would input a URL that doesn't allow me to search inline, like a URL that's like this Youtube.com/user/rhe8rghshdughsuerg. Drives me crazy. I have a love-hate relationship with Chrome. –  theGreenCabbage Mar 14 at 14:05
add comment

2 Answers

up vote 4 down vote accepted

Sadly, there is still no way of disabling the feature. It has been a complaint of many users for quite some time, with google still offering no solution other than pressing the down arrow prior to hitting the return key, or consistently clearing your history so it has nothing to assume.

Forum discussion of rage discussing this exact problem: http://productforums.google.com/forum/#!category-topic/chrome/discuss-chrome/0DR-pLIVI5g

I'd love to see this changed myself. It drives me insane.

share|improve this answer
    
Is that so? I guess I'll just have to sign out of Chrome if I want to get a decent search result. Thanks! –  Ieyasu Sawada Jun 16 '12 at 12:20
    
Not a problem. I was hoping a few upvotes would bring in a user who has found a workaround. Guess not. –  Myersguy Jun 16 '12 at 21:55
add comment

Found it...

  1. Open C:\Users\<User>\appData\local\Google\Chrome\User Data\Default\Preferences in notepad (replace with your username).
  2. Search for "default_search_provider".
  3. Right below it is "enabled: true".
  4. Change the true to false.
  5. Save the file.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.