Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to create a single LVM volume on my SD card, using Ubuntu Netbook Remix. The SD card is at /dev/mmcblk0. So far, I've used fdisk to create a partition (type 8e - Linux LVM) on the device. The partiton is /dev/mmcblk0p1. However, when I run

sudo pvcreate /dev/mmcblk0p1

I only get this response:

Device /dev/mmcblk0p1 not found (or ignored by filtering).

As the Ubuntu Guide suggests, I've tried looking at my /etc/lvm/lvm.conf, but the filter seems to be ok - the problem remains even when the default option is enabled.

# By default we accept every block device:
filter = [ "a/.*/" ]
# Only devices beginning with "mmcblk":
# filter = [ "a|/dev/mmcblk.*|", "r/.*/" ]

I assume the problem is somewhere within the LVM configuration, since when I run sudo vgscan -vv with the default "accept every block device" configuration, it lists many devices being scanned - however not the /dev/mmcblk devices. When using the more restrictive filter, it scans no devices.

My complete /etc/lvm/lvm.conf is available online for inspection.

I've tried reading multiple guides about setting up LVM ([1],[2],[3]), but none of them seem to be of help with this issue.

Any ideas what is going wrong? How would I troubleshoot this issue further?

share|improve this question
@derobert: Right, so it's actually a bug with lvm2 - thanks for the link! It seems this is "Fixed in lvm2-2.02.45-4.fc11". Now I'll just have to see how to get that version on Ubuntu Netbook Remix... – Ilari Kajaste Sep 20 '09 at 7:10
There is a workaround in the bug (or, rather, two): either change the name to something lvm will understand via udev or types = [ "mmc", 16 ]... I'd post as an answer, but I have no way to test either of those. – derobert Sep 20 '09 at 21:40
@derobert: Looking at the man page, udev seemed quite a hassle, since I'm not familiar with it. However, editing /etc/lvm/lvm.conf to include the types definition worked! So feel free to post is as an answer to get the reputation. :) – Ilari Kajaste Sep 23 '09 at 10:40
up vote 1 down vote accepted

According to bug report 483686 on Redhat Bugzilla (link provided by user derobert) this is actually caused by a bug in lvm2. "lvm2 doesn't understand mmcblk devs."

The bug is reported "Fixed in lvm2-2.02.45-4.fc11 / lvm2-2.02.45-4.fc12" on 2009-04-17. So what remains to solve the issue is getting the fixed version of lvm2 on Ubuntu Netbook Remix.

In the meantime, there's an easy workaround. Adding a types definition to the devices section of /etc/lvm/lvm.conf fixed the issue:

# Hackaround to get LVM to understand mmcblk0 as a device,
# bug report at bugzilla.redhat-com/show_bug.cgi?id=483686
types = [ "mmc", 16 ]
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .