Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've set to in my /etc/hosts file in (located here on Windows: C:\Windows\System32\drivers\etc\hosts).

Though Chrome loads with the one hosted locally on port 80, Firefox loads the actual

How do I get Firefox to load my locally pointed

share|improve this question
Firefox doesn't do that. It uses the OS DNS resolver to convert names to IP addresses. So it depends on how the resolver is configured. Applications such as Firefox have nothing to do with it. – Keith Jun 16 '12 at 15:02
So how do I configure its resolver to resolve as – A T Jun 16 '12 at 16:10
Does Firefox have a proxy manually configured? If so DNS will be offloaded to the proxy server. – Zoredache Jun 16 '12 at 17:29
@AT That's a Windows admin thing, and I don't do Windows. The fact that that file is in a directory named "drivers" is completely bizarre. I think there is some GUI tool to set these. – Keith Jun 16 '12 at 17:53
@Zoredache Nope, it has precisely the same proxy settings as Chrome. Keith: Not sure. – A T Jun 16 '12 at 18:29

2 Answers 2

I've ran into this problem before. It seems like Firefox is caching the /etc/hosts file in some fashion. Give it some time.

share|improve this answer

@guns answer to another question (about DNS lookup) helped me out on this issue. Basically, if a site has an IPv6 address, you need that in your hosts file, too.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.