Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I type in a 16 digit number (format: number, no decimals) it changes the number on me. Example: 1234567812345678 changes the view to 1234567812345670.

If I type it in as a general format it changes the numbers above so it displays 1.23457E+15 but if you click on the cell, the display shows the last digit as a 0 instead of an 8 once again.

I opened the file on a different computer and same issue now with it. I have changed the auto correction and auto formatting all to no avail. Help!

share|improve this question
    
"16 digit number" suggests a credit card number, which definitely should not go in an (unencrypted) spreadsheet and is subject to strict security regulations. –  PleaseStand Jun 17 '12 at 22:10

3 Answers 3

It is a limitation placed on Excel by Microsoft. Each cell can have a maximum 15 digits of precision.

http://office.microsoft.com/en-us/excel-help/excel-specifications-and-limits-HP005199291.aspx

enter image description here

share|improve this answer
    
+1 "This is caused by the IEEE specification of storing only 15 significant digits of precision." (Source: support.microsoft.com/default.aspx?scid=kb;en-us;78113) –  Ellesa Jun 16 '12 at 22:44
    
Not the answer I wanted, but I appreciate the reason for why it was driving me crazy. Thanks for taking the time to answer! –  Going Crazy Jun 16 '12 at 23:14

In addition to wbeard52's answer, here are some workarounds:

  1. Entering the numbers as text. You may type a ' before each number, or change the cell's number format to Text.
  2. There's an addin called Xnumbers which "performs multi-precision floating point arithmetic from 1 up to 250 significant digits."
share|improve this answer

you can copy and paste a column of 16 digit numbers into excel like this:

Open a new excel document.
Leave it blank then click FILE / SAVE AS.
From the type box, select "text (tab delimited file)" option.
Format the column where you want to paste the 16 digit numbers as "text".
Copy your 16 digit numbers from the original document (word, email, where ever they are) and paste them into the column in the tab delimited file that you just formatted as text. Save it again.
You will see an error warning. Select all of your 16 digit numbers and select "ignore error" from the list of error handling options.
Keep the file as a text file or save it as an excel file, it works either way. You might see the error warning again, just select all and ignore error again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.