Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to compile some files related to wireless subsystem (mac80211) which use datatypes u8, u16, u32, u64. These are not resolved. The header file being referred to is linux/types.h which is included. However, __uxx data types are being recognized. I tried including the asm-generic/types.h but the problem doesn't get solved. Any pointers?

share|improve this question

1 Answer 1

Strange – if it were user space, you'd need to use it with prefix __ (e.g. __u32), but mac80211 is kernel related project.

Note: It does not matter whether you include <linux/types.h> or <asm/types.h> as the first includes the second. IMHO you should not include <asm-generic/types.h> (which is included by <asm/types.h>) due to portability.

See more info in LDD.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.