Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Windows PowerShell. Let's say I have a script called test.py that prints a few things. If I do:

PS D:\>.\test.py

then it opens a CMD window which prints a few things and then closes. It's actually running the Python interpreter under CMD. If I do

PS D:\>python test.py

it acts like I'd expect it to, with the output appearing in PowerShell.

How can I make it so that the script will run in PowerShell when I just give its name?

share|improve this question

2 Answers 2

up vote 13 down vote accepted

Edit the PATHEXT environment variable and add the .py extension.

Just add this line to your powershell profile:

$env:PATHEXT += ";.py"

or you could just edit PATHEXT globally using the system settings (just start menu search for "Edit Environment variables for your account").

share|improve this answer

You might have more than one version of Python installed and the version IDLE is using is newer. To see what version of python you have you can type >python -V at a command line. If that version looks appropriate then you might need the full path to the file as the second parameter. E.g >python C:\myfile.py.

If you installed Python correctly there is always a chance that just typing the name of the script will run it with python. E.g. >myfile.py

I always find that adding C:\Python27 to the %PATH% variable and .PY to the %PATHEXT% variable makes running scripts easier. In this case just >myfile should work.

Edit after Update:

Typing just >python with no parameters opens python in 'interactive mode' which is different from the batch or scripting mode that your script is intended for. If executed with arguments the first argument is taken as the file path and further arguments are passed to the script in the sys.argv list.

share|improve this answer
    
Why do you copy and paste your answer from somewhere? You even forgot to copy the formatting properly, and there was no "Update" in there. –  slhck Jun 17 '12 at 6:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.