Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought the device in subject to extend the range of my WPA2/PSK-protected wifi network powered by a TP-Link TL-WR340G device (AP+router).

I configured it as follows:

  • Operation mode: Universal Repeater
  • MAC of AP: scanned my SSID and got it
  • Channel width: 20MHz
  • Security options: the same as the parent AP (WPA2/PSK with AES encryption)

After configuration inSSIDer shows me two APs beaconing the same SSID at different SNRs (because I was with my laptop close to the extender). After a few hours my tablet, far from the parent AP, stopped working. I found that the scan reported two networks with the same SSID: one WPA-protected and one free at all. This happened very frequently. Rebooting the extender by unplugging it worked but this doesn't last long.

Sometimes the extender stops transmitting at all, sometimes it beacons an open network to which nobody can connect (because there is no DHCP).

What's wrong with my configuration?

share|improve this question
    
Device sounds broken. –  Ƭᴇcʜιᴇ007 Jun 17 '12 at 14:52
    
Still, it's unusual that I can access it (192.168.128.4) from my hard-wired desktop PC :D –  djechelon Jun 18 '12 at 18:44
    
Not unusual at all. Hardware address rewriting is only needed for clients of the repeater. –  David Schwartz Jun 25 '12 at 20:52
    
I've replaced the device and the problem persists –  djechelon Sep 28 '12 at 10:51

2 Answers 2

up vote 0 down vote accepted

Universal repeater mode has terrible compatibility and should not be used with an AP that has WDS unless you have absolutely no choice. The Wifi spec prohibits an access point from sending packets to a client unless they are addressed to one of its clients' hardware addresses. "Client repeating" systems have to use tricks to induce the main access point to send the repeater traffic for its clients even though they aren't the main access point's clients.

Switch both APs to WDS mode.

share|improve this answer
    
How do I enable WDS on TL-WR340G (main station)? –  djechelon Sep 28 '12 at 10:53
    
I've found the solution. WDS doesn't support WPA, so I must completely change my perspective –  djechelon Sep 28 '12 at 11:29
    
@djechelon: It does not support WPA officially, but it actually works fine with it. You may need to use aftermarket firmware to be allowed to enable it. –  David Schwartz Sep 28 '12 at 20:01

While I haven't found a permanent solution for the unprotected network that appeared (rather than changing mode to plain Repeater) I found that my internet access was sometimes prevented from authenticated clients because of an enabled DHCP server that had a misconfigured gateway

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.