Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 1TB internal western digital hard drive which seems to have gone missing in action. When it was first installed I had no issues with it and decided to partition it to be able to allow me to keep work / personal stuff separate. So 1 had all my work files (4 years worth) and the other had all my family pictures, videos, drivers and other files.

I went to get a file the other night and the drive had just vanished, I restarted the system thinking it would just reconnect type of thing but it never did. I tried adding the drive letter in my computer > manage > disk management and that didn't work so I removed the letter. The drive has not web formatted although it wanted me to when I hanged the letter of the drive. It shows in disk management as a the drive but says unallocated and there is nothing in the file system part, whereas there is for my local c drive.

I ran a trial program of recovermyfiles and it showed as the files being there but it took over night plus a few hours as there is that much data.

I was advised by a friend to run it in ubuntu through a pen drive - so I loaded ubuntu and it says the drive is ok, but again you can't go in to the drive?

I was hoping there is a way I can restore the drive so that I can take what I need and format it and start again.

Please tell me that I haven't lost all this as I think it may send me over edge - your help will be greatly appreciated!

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

You can use testdisk, it is completely free and will recover your most of data.

share|improve this answer
add comment

Before you do anything:

  1. Check if your backups are up to date.
  2. Make a backup of the drive. E.g. by dd'ing it to a file.

This way you can go back to where you are now if some recovery attempt makes things worse.

As for recovering:

  1. Make that backup
  2. Check the partition table of the drive. It is MBR? GPT?
  3. Add that information to your post. Depending in the results you will get different answers. (e.g. a GPT table which looks corrupt would probably gets answers pointing to the GPT backup at the end of the drive.
  4. If recoverable, mention which filesystem you used. (atm my guess is NTFS)

...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.