Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have iPhoto 09 (version 8.1.2 build 424) that either hangs when opened from the dock, or crashes when opened by clicking on iPhoto library.

I tried the following to troubleshoot:

  • made a copy of the library, and assigned it as the strartup library
  • verified that user account has "write" permissions on the library
  • my iMac has two admin users. Gave permissions to the second admin user, assigned this library as a startup library and was able to open it from the second account.

Please help me troubleshoot. There is a similar question asked recently with no resolution as of yet.

If it helps, here is a top portion of the error message:

Process:         iPhoto [36840]
Path:            /Applications/iPhoto.app/Contents/MacOS/iPhoto
Identifier:      com.apple.iPhoto
Version:         8.1.2 (8.1.2)
Build Info:      iPhotoProject-4240000~8
Code Type:       X86 (Native)
Parent Process:  launchd [182]

Date/Time:       2012-06-17 12:53:41.471 -0400
OS Version:      Mac OS X 10.6.8 (10K549)
Report Version:  6

Interval Since Last Report:          99090 sec
Crashes Since Last Report:           2
Per-App Interval Since Last Report:  10400 sec
Per-App Crashes Since Last Report:   1
Anonymous UUID:                      3E8F45F5-884A-4E62-8E1B-7F7CB85586E3

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread:  0  Dispatch queue: com.apple.main-thread
share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.