Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've used this question's answer by user "Moab" to give myself permission to delete an empty folder, so that I no longer get "accessed denied". However, now when I try removing this folder, I get a message that says "The process cannot access the file because it is being used by another process." This is merely my "eclipse" (IDE) folder that I totally emptied out and am trying to delete, but for some reason cannot. I've tried quite a few things:

  • Via Windows Explorer:

    • Right Click -> Delete
  • Via Command Prompt

    • RD /S /Q eclipse
    • del /F eclipse
    • rmdir /S eclipse

I'm out of ideas, and I'd really like to delete this folder without having to install any software. I've done a bit of research and this is all I found that I could try. Does anyone have any other ideas?

share|improve this question
Is Eclipse running? – Bibhas Jun 17 '12 at 19:34
No, it was not. – Mike Gates Jun 17 '12 at 19:43
Do you have hidden files shown? Folder Options > View > Show Hidden Files, Folders, and Drives – Usta Jun 18 '12 at 3:25
I do have hidden files shown. The problem is resolves now though. – Mike Gates Jun 18 '12 at 16:09
up vote 0 down vote accepted

Well, it appears I've already solved my problem... well, perhaps this answer will help anyone else who views this question with a similar problem!

How could one forget about Safe Mode? I restarted my computer, held down F8 until I could choose to run the computer in Safe Mode with Command Prompt, and deleted the folder simply with rmdir /S eclipse, and finally issued a shutdown -s. Now I'm back and the darn folder is actually gone! It appears Safe Mode disallowed whatever "process" was "using" that eclipse folder from preventing me from deleting it.

share|improve this answer
Why on earth does Windows require a reboot to delete an empty folder? Further evidence that this OS is a joke, and we all have been punk'd... sigh – weberc2 Jan 3 '13 at 18:32
  1. at first, log off your machine and then remove this folder;

  2. download "Unlocker" this software,install unlocker, right click this folder -->select unlocker --> select delete --> start

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .