Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Samsung RC720 notebook with Intel Integrated Graphics and NVIDIA GeForce GT 520M.
As you can see it has two video adapters and Optimus is supposed to switch between them. But when I choose dedicated GPU in NVIDIA Control Panel and try to run, for example, GTA IV, it uses integrated graphics and I get very poor performance.

I have already installed last NVIDIA and notebook drivers, chose high-performance in NVIDIA Control Panel, tried to execute with "Run with graphics processor..." context option and so on.
Thanks for help.

share|improve this question

3 Answers 3

Download and use the latest drivers from the notebook manufacturer website, both Intel first and the Nvidia. Once installed, download the latest driver from Nvidia. Start the program and after it does the compatibility check, cancel the installer. Click start, right click "My Computer" and select properties.

In the popup window on the top left side, click device manager. In this popup window, find your Nvidia under "Display Adapters", and select update driver software. Select "Let me pick", have disk and then browse to the unpacked Nvidia folder which is by default C:/Nvidia and continue in until you get to Display driver. It will find the .inf itself and select open. When it reloads back to the screen where your driver is listed click to install and allow it to finish.

Reboot and your Nvidia works with the latest Video driver. Unfortunately, there is no way to update the Optimus controller and it still work and if you update the Intel video driver from Intel it will break as well.

The older Optimus controller with the latest Nvidia video driver works fine with all of the benefit of the new display driver and it does not matter that you have older Intel video driver as it will default to Nvidia anyways with the higher performance need.

OH! Do not update the physX system software as it will break the Optimus also!

share|improve this answer

Not sure, never had this problem before, but what happens if you disable your integrated GPU through device manager?

share|improve this answer
    
The screen blacks out completely. –  user140739 Jun 20 '12 at 0:02
    
Try to uninstall the integrated graphics driver and then next install the NVIDIA graphics driver, perhaps the integrated card be disabled and thus in turn enable the NVIDIA one. Alternatively, you could try to modify the bios of a laptop to disable optimus. Probably won't do anything but have you tried using the other VGA port? –  wonton Jun 20 '12 at 16:59
    
No, uninstalling integrated card and installing nvidia card leads to a situation in which I only have small resolution screen and system always tries to use a card with no drivers. And there is no such option in bios. –  user140739 Jun 20 '12 at 23:14

My lap has the same issue(samsung NP300E5x-S01IN). In My case problem was with BIOS. My Bios version is p04RAC. Updated it to p07Rac and geforce 610 m got detected in windows 8.1. But the problem was that sata gen 3 disappeared from bios, after update and my ssd was switched to sata 2.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.