Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had a problem with ubuntu a few days ago so I decided to uninstall it. Ubuntu was installed "inside windows" so I just uninstalled it as you uninstall any normal program. This normally works for me, but for some reason now when I start my computer it still asks me to choose ubuntu or windows, when I don't have ubuntu installed anywhere (and if I choose ubuntu I get an error saying there's nothing to boot). I've been trying to figure out how to delete this unexisting OS which I don't know why my computer thinks it's still there. If I try to re-install ubuntu I will get 2 Ubuntu options on the multiboot option. Is there any easy way to fix this without having to delete everything from my HDD? Thanks in advance!


Edit: I think I should emphasize that there was no "extra partition", both OS were on the same partition (I used the "install inside windows" option from Ubuntu)

share|improve this question

migrated from stackoverflow.com Jun 17 '12 at 22:37

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 2 down vote accepted

Either windows added Ubuntu to it's own bootloader or a thrid party boot loader was installed.

To remove it from the windows boot loader. Go start> Search and run MSCONFIG. Under the "Boot" tab, There should only be one listing. IF your ubuntu is listed there Delete it.

If it's not you can use the below links to restore your boot loader completely.

Windows 7 Windows vista Windows XP

share|improve this answer
    
I tried MSConfig but there's no ubuntu there. I also tried with bootrec /fixmbr and bootrec /fixboot but they didn't work either. Any other suggestions? –  waclock Jun 17 '12 at 23:12
    
... did you try the link below? –  ekaj Jun 17 '12 at 23:19
    
Yes, I tried fixing the master boot record but it didn't work. I also tried with the "repair the computer option" and nothing was wrong. –  waclock Jun 17 '12 at 23:37
1  
Try running bcdedit.exe from the command prompt . make sure you run cmd as a Admin. Does it have more then one identifier under Windows boot loader ? you can delete other entries using bcdedit /delete <name of identifier> .. there is also a program easybcd that will give you the same options but in a GUI interface. Easybcd also will alow you to re-write the MBR under BCD Deployment. –  animepunkw Jun 17 '12 at 23:47
    
Thanks! easybcd did it! :) –  waclock Jun 18 '12 at 0:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.