Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Brief description:

cloned HDD1 -> HDD2

  • HDD1 partition 1 boots
  • HDD1 partition 2 boots
  • HDD2 partition 1 boots
  • HDD2 partition 2 doesn't boot Windows, but is bootable in general

Now verbosely:

In all the cases computer is the same.

I have two Windows 7 installations on HDD1 - both are booting fine. I choose between them using standard Windows 7 boot loader menu. Technically there are 4 partitions: 100 MB Boot loader partition (active), Windows 7 copy 1 (25 GB), Windows 7 copy 2 (150 GB) and Working partition. All are primary.

In past few days I tried to clone the whole HDD1 to HDD2 of the same size (but 2,5 inch form factor) as is using Minitool Partition wizard. Everything has been copied, all files are accessible, no faults in file system structure, even boot loader wasn't damaged and I hadn't to repair it.

But I can boot only first installation of Windows 7 (it boots without issues). When I choose the second installation, I get immediately a completely black screen without any texts, cursors and other data. HDD isn't accessed after that. This black screen is sensitive to Ctrl-Alt-Delete which causes computer reboot.

I did some experimenting: Installed Windows 7 to that partition - it booted fine. Then I renamed "Windows" to "Windows.old" and copied Windows directory from HDD1 as it was, using Far Manager, and got the same troubles - black screen. (Of course I performed renaming and copying from other copy of Windows). So, it seems that problems are inside this installation of Windows, somewhere in its files.

share|improve this question

migrated from serverfault.com Jun 18 '12 at 7:00

This question came from our site for system and network administrators.

2 Answers 2

up vote 1 down vote accepted

Miracle happened.

I have two computers: Desktop and Laptop. What I wanted to do was to clone desktop's 3.5 inch HDD to 2.5 inch HDD, plug it to ESATAp port and use it in VMWare as a physical disk. Both HDDs are of the same size and same rpm. The source disk had 2 Windows 7 copies with boot menu.

I plugged the 2.5 HDD to second SATA port of desktop computer, cloned the whole disk only to discover that one of two Windows installations is not bootable from 2.5 HDD on desktop PC.

Today I decided to plug 3.5 inch HDD to laptop and use it as a physical drive in VMWare. This effort has failed. I couldn't eliminate disk reading errors even after switching the HDD to offline mode.

But when I did the same with 2.5 inch HDD everything began to work without having to install or reinstall something! I can't explain why the clone succeeded and source - not, but it works!

share|improve this answer

It might be one of the issues below :

  1. CTRL-ALT-DEL is built in hardware command as far as I know so it won't be a sign windows loading
  2. On old HDD's it might be a matter of jumpers / setting it on slave / master .
  3. Please look if AHCI is enabled for that disk .
  4. An issue with the boot loader / MBR , please see this document http://answers.microsoft.com/en-us/windows/forum/windows_7-system/boot-manager-installed-windows-7-twice-how-to/a8ece38a-2de8-4931-9068-d86aeb4e4da4 .

If that doesn't help I have a question:

  1. Is the second HDD accessible from the first instance of win7 ?(if yes , it's most likely an issue of point 2-3 ).

I hope this helps :) .

share|improve this answer
    
It is not only accessible, I can even BOOT from HDD2, but only the first Windows copy. –  Paul Jun 7 '12 at 8:53
    
Then I think it's an issue with boot loader MBR , please see point 4 from my list . –  Alex H Jun 7 '12 at 9:03
    
It isn't a boot loader issue. I added and deleted boot entries several times. The boot loader is able to find all 4 copies of Windows 7 - on old and new HDDs, but one of them can't start. –  Paul Jun 12 '12 at 19:49
    
Can you please backup the mbr then let only the entry that doesn't work to be the only one ?(this can be checked at booting ) . I might be wrong but I haven't seen so far 4 entries in MBR that worked (maximum 3 ). –  Alex H Jun 12 '12 at 20:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.