Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After adding the Developers tab in Excel 2010, the Record Macro function became disabled.

How can I enable it again?

share|improve this question

2 Answers 2

Save as a Macro Enabled workbook.

1) Click the Office button and then click Save As. The Save As dialog box appears.

2) Enter a name and select a location for your workbook.

3) Click the Save as Type drop-down arrow. A list of file types appears.

4) Select Excel Macro-Enabled Workbook (*.xlsm). Excel adds the .xlsm extension to the filename.

5) Click Save.

OR

Change the settings of Digital Certificate for VBA Projects and Visiual Basic for Applications to Run from My Computer. Follow this on how to Install or remove individual Office programs and components.

Hope this helps.

share|improve this answer
    
Even i did first step i didnt understood what the "Change the settings of Digital Certificate for VBA Projects and Visiual Basic for Applications to Run from My Computer." –  Mahesh Jun 19 '12 at 7:07
    
Follow the link to change the settings. –  ahmed Jun 19 '12 at 8:50

First click the File Menu(Office Backstage) and select Options from the left sidebar. In options, select Trust Center from the left sidebar and click Trust Center Settings button on the main window.

Now in Trust Center Settings dialog window, select Macro Settings from the left sidebar, choose Enable All Macros option and hit OK.

share|improve this answer
    
I enabelled already that, then also no success. after that only i raised that question can you tell me any other alternative. –  Mahesh Jun 18 '12 at 11:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.