Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got this weird sound issue on Firefox, which I've noticed on a lot of YouTube videos. Normally this happens in sound mixer:

But then, when navigating to another YouTube video this happens:

I didn't change any setting or anything – I'm confused. I should also mention that besides my main output source there is a USB headset output... if this has anything to do with my problem.

share|improve this question
    
Well, is there sound coming out of the USB headset? –  Bob Jun 18 '12 at 12:38
    
nope, no sound output at all –  krasatos Jun 18 '12 at 12:45
    
sometimes adobe flash player is missing from the sound mixer... so i restarted ff having my speakers as a default audio output and it seems to work... tried a couple of videos that were not working before and they work ok... so maybe it has to do with html5/flv type of videos? anyway i will test more and report back if it is still broken or if it's corrected. –  krasatos Jun 18 '12 at 12:48
1  
I never have Adobe Flash Player in there at all. On another note, do you have the same issue if you remove the USB headset? Flash vs. HTML5 should not make a difference. –  Bob Jun 18 '12 at 12:58
    
Do you use the latest version of Flash ? –  HackToHell Jun 18 '12 at 14:16
show 1 more comment

1 Answer

Try turning the volume down a bit on the YouTube video from within the YouTube player (it's weird, I know, but it worked for me).

I was having the same problem - Sound worked fine for some youtube videos but not others - the sound on some videos was nonexistent or I would just hear quiet pops and crackles.

I updated Flash, disabled my old flash plugin in Firefox (tools->addons->plugins) and restarted Firefox to no avail.

Then, I turned the volume down within the YouTube player and I could hear the sound properly. I think that on some of those videos, they try altering the sound track to make them louder and it causes a glitch where the sound won't play... That's my best guess as to why this worked for me.

Good luck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.