Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just upgraded my CentOS 5.4's Samba 3.0.33-3.15.el5_4 to 3.6.4 built from source. I copied over config and stuff from the old distro-locations to the source-expected location in /usr/lib. I copied over the config options I changed from the default smb.conf from 3.0.33 to the new default config. I'm using an ADS setup and my Windows client now says my domain password is incorrect. I don't see anything happening in log.smbd

OLD testparm output:

Load smb config files from /etc/samba/smb.conf
Processing section "[hactar]"
Loaded services file OK.
Server role: ROLE_DOMAIN_MEMBER
Press enter to see a dump of your service definitions

[global]
        workgroup = XXX
        realm = DS.XXX.EDU
        server string = Samba Server Version %v
        interfaces = lo, eth0
        security = ADS
        username map = /etc/samba/smbusers
        log file = /var/log/samba/log.%m
        max log size = 50
        socket options = TCP_NODELAY IPTOS_LOWDELAY
        local master = No
        wins server = 10.109.18.219
        cups options = raw

[hactar]
        comment = Galactic Supercomputer Filesystem
        path = /hactar
        valid users = root
        read only = No
        delete readonly = Yes

NEW testparm output:

Load smb config files from /usr/lib/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[hactar]"
Loaded services file OK.
Server role: ROLE_DOMAIN_MEMBER
Press enter to see a dump of your service definitions

[global]
        workgroup = XXX
        realm = DS.XXX.EDU
        server string = Samba Server Version %v
        interfaces = lo, eth0
        security = ADS
        username map = /etc/samba/smbusers
        log file = /var/log/samba/log.%m
        max log size = 50
        socket options = TCP_NODELAY IPTOS_LOWDELAY
        local master = No
        dns proxy = No
        wins server = 10.109.18.219
        idmap config * : backend = tdb

[hactar]
        comment = Galactic Supercomputer Filesystem
        path = /hactar
        valid users = root
        read only = No
        delete readonly = Yes

What's going on?

share|improve this question
    
I just reverted to the old version. Actually found there was an update in the EL5 repository for samba so I upgraded via yum and that worked ok. Hopefully it includes the necessary security fixes. – Matt Chambers Jun 21 '12 at 2:04

I had same issue, it was caused by compiling with wrong path settings. While tracing wbinfo -t using strace and looking for open fd's of winbind daemon using lsof -p. I noticed that new binaries in the rpm were looking at wrong places for pipe and some .tdb files. So after recompiling the rpm with new paths it worked fine.

/tmp/.winbindd/pipe -> /var/run/winbindd/pipe
/etc/samba/secrets.tdb -> /var/lib/samba/private/secrets.tdb
/etc/samba/passdb.tdb -> /var/lib/samba/private/passdb.tdb
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .