Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to RDP to another computer on a LAN and sometimes get the folllowing error:

This computer can't connect to the remote computer. Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator.

This only occurs sometimes and not very frequently. What is causing this to occur?

share|improve this question
Are you trying to connect via ip address or host name? – jmreicha Jun 19 '12 at 19:42
@jmreicha: hostname – CJ7 Jun 20 '12 at 4:39
I would suggest trying to replicate the problem connecting by ip address only. If you can't reproduce the symptoms the culprit would likely point at DNS or WINS. – jmreicha Jun 20 '12 at 13:19
I'm embarrassed to admit that I got this problem, then realized I hadn't clicked the "apply" button after "Allow users to connect remotely to this computer" had been checked...after I did then it worked. – rogerdpack Dec 19 '14 at 13:41

first check are you able to ping the remote machine in the LAN. from command prompt type this ping remote machine ip address example


if you are still not able to do that check one time by turn off the firewall of the remote machine.

share|improve this answer

From where you trying to connect remotely. Is remote computer has firewall, router? Is your local computer is behind firewall ?

share|improve this answer
It is over LAN. The problem occur only sometimes. – CJ7 Jun 19 '12 at 9:43
May be something goes wrong with DNS or your LAN 'refresh' on specific time. Also if u didn't check yet what @Untraceable mention, check it. – Jason Paddle Jun 19 '12 at 10:07

I have the same problem and just found out, that the problem only occurs after Windows installed some Windows Updates (don't know exactly which ones). Then the Remote Connection does not work anymore.

To fix the problem: Uncheck the Allow users to connect remotely to this Computer (in System Properties) and restart the Computer. Then re-enable it and then it works again.

share|improve this answer

Just ran into this today. The problem was actually a very simple one: the credentials that Remote Desktop was using automatically were for a different computer, and it was automatically being rejected.

So, for example, I had just connected to ComputerA as Administrator, so Remote Desktop tried to sign into ComputerB as ComputerA/Administrator, not ComputerB/Administrator. Changing the sign-in name fixed it immediately.

share|improve this answer
FYI i would not recommend saving your remote desktop credentials if you can help it. All it takes is for someone to grab your RDP file and they will be able to login to whatever computers you are saving credentials for. Also, I think the error message is quite different if you try to login to a server using credentials that dont match up with the server you are trying to connect to. – Richie086 Dec 13 '13 at 20:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .