Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

At work I've 4 different computers connected using a keyboard/video/mouse switch.

Quite often when I switch to windows vista the resolution is totally wrong and I need to get the screen properties dialog, change to another wrong resolution (because the funny part is that the current resolution listed in the dialog is apparently the correct one) then re-switch to the correct resolution.

I would really like to just shut that broken resolution autodetection code off. Is there a way to disable screen resolution autodetection in Windows Vista?

share|improve this question
    
There is a long thread about this problem in Windows 7 on answers.microsoft.com/en-us/windows/forum/windows_7-hardware/…. Looks like there is no real solution, but some users have given workarounds that might help here too. –  Gurken Papst Jun 26 '12 at 21:04
    
@GurkenPapst: It seems to me like the solution is right in the second post on that thread. –  Oliver Salzburg Jun 27 '12 at 8:18
    
@OliverSalzburg: that is not a solution, it's just blaming hardware for problems that are software related. The other PCs connected to the same KVM switch are XP pro (laptop with docking station), XP embedded and Linux. None of them has problems. Are you going to consider this comment also offensive and censor it? Are you going to censor all the 300+ posts in that thread? –  6502 Jun 27 '12 at 10:54
    
@6502: What gives you the impression that I am censoring or even could censor anything? By the way, maybe this question is helpful: superuser.com/questions/96683/… –  Oliver Salzburg Jun 27 '12 at 11:20

2 Answers 2

up vote 2 down vote accepted
+50

To disable checking for monitor-change see this article :
How to Disable or Enable the Transient Multimon Manager (TMM) in Vista.
TMM (Microsoft Transient Multi-Monitor Manager) is a task defined in the task scheduler. Disabling it might solve your problem.

If not, another fix for Vista only is described here, which consists of defining in the registry at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\TMM a DWORD item called UseIViewHelper and setting its value to zero.

share|improve this answer
    
I was only able to test this for a single day so I'm not sure this works (the problem is not always showing). So far seems ok now. –  6502 Jul 3 '12 at 8:35

Ok, simple solution to not fiddle with monitor drivers (impersonation) and system registry (disable pnp detection)...

Download this tool for each pc
the 32 bits version
or
the 64 bits version

Create a shortcut and add the extra parameters to the shortcut (*.lnk file in windows)
set the different resolutions you want in each pc (see one example below)
put the shortcut in the startup folder of each pc... and... voilá!!!
simple and clean solution

example for 1024x768 in 24 bit color >> nircmd.exe setdisplay 800 600 24

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.