Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here is my setup. I have a Macbook, Thunderbolt display and an Ethernet connection plugged into the Thunderbolt display.

During the day, most of my network use can (and should) operate across the ethernet associated with my display. However, I also need to be able to connect up to a wireless router. This hasn't been a problem on the Mac OS X side, but the program that I need to run on the router has to obtain an IP address from the wireless access point.

Considering my current setup, how can I leave it so that I can access the internet in OS X, yet have my Window 7 instance running in Parallels, get it's assigned IP address from a wireless router that my Mac is also connected to?

I've fiddled around with the Parallel's network settings for an hour, and I can't get Parallel's to see the router, even though my Mac is certainly connected to it.

UPDATE

Thanks to Emgee for providing the correct answer, however, there was something else going on that I was able to fix via trial-and-error.

After setting and resetting the various network options I was able to get my guest OS to obtain an IP address from the WiFi router. I'm not sure what step I executed fixed Parallels, but I tried to following steps and, eventually, Windows 7 "magically" started talking across the network.

First, I shutdown Windows 7 and went into the hardware configuration of Parallels where I deleted ALL of my network adapters (I had two, because I tried to create a second one, specific to the WiFi connection.) After deleting all of them, I created a new one and specified it as a bridged, WiFi connection. I also, hit the Generate MAC Address button a few times, just in case Parallels was cacheing addresses.

After reseting my network connection, I restarted Windows and I was able to obtain an IP on my WiFi subnet. Sending pings in both directions verified that I was able to send and receive data both ways.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

In the Parallels virtual machine settings for the Windows 7 Machine, set up the networking as Bridged (rather than NAT or Shared), then there should be an option to select which network interface to connect to. You'd then choose your wireless adapter.

I use VMware, not Parallels, so I can't direct you more specifically which the exact option names are.

share|improve this answer
    
Yes, I did this, but my IP is still coming from the router that my Ethernet is coming from. In my case, my wireless router gives out IPs in the 192.168.3.xxx range, while the Ethernet router gives out addresses in the 192.168.100.xxx range. I even changed to the recommended settings and restarted the computer. It is worth noting that running 'ipconfig /renew' also hangs in Parallels. There must be something else that I must need to do. –  RLH Jun 20 '12 at 12:35
add comment

This works for me. In Parallels Windows 8 Machine, I choose Configure > Hardware (Tab) > Network 1 and choose Networking type as Airport and DHCP server as Auto

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.