Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I compiled git wine 1.5.6 and the sound is not working correctly.

winecfg gives a message:

ALSA lib ../../pulse/pcm_pulse.c:995:(_snd_pcm_pulse_open) Unknown field handle_underrun
err:winediag:AUDDRV_GetAudioEndpoint PulseAudio "default" -22 without handle_underrun. Audio may hang. Please upgrade to alsa_plugins >= 1.0.24
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded

But on wheezy there is no package lib32asound2-plugins 1.0.25 So, how do I build and package alsa-plugins to install to lib32? Or how do I use automake's configure to compile a 32bit lib on a 64 bit system.

All I Need now is the libavcodec-dev for 32bit, but I don't understand. What is the 32bit libavcodec-dev package for amd64 debian?

share|improve this question
add comment

2 Answers

I Solved this by downloading the source packages of zlib and libopenjpeg. Then recompiling them with multi-arch support.

share|improve this answer
add comment

You're on wheezy/testing or sid/unstable, aren't you? I ran into it and solved it by grabbing squeeze's copy and dpkg -i it in.

share|improve this answer
    
This has changed in the past few years (not sure when, but I've just learned better). Debian transitioned away from ia32 libs to multiarch, so you'll have to go that route. dpkg --add-architecture i386 apt-get update apt-get install libasound2-plugins:i386 More can be found on the relevant wiki. –  nonconvergent Jan 27 at 14:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.