Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We have a Dell Poweredge 2900 system with Dell Perc 5/i card and 4 SAS hard drives attached, with NTFS partitions on them. We installed CentOS on one raid array on this controller with a different controller and it is working fine.

We are now trying to access the drives shown above and they are not being shown in /dev as sdb, etc.

sda is the drive that we installed centos on and it has sda1, sda2, sda3, etc. The CDROM has been picked up as well.

If I scan for scsi devices then the perc and adaptec controllers are both found. sg0 is the CDROM and sg2 is the centos installed, however I think sg1 is the other drive but I cannot see anyway to mount the partitions, as only the drive is listed in /dev.

Thanks.

EXTRA INFO

fdisk -l:

Disk /dev/sda: 72.7 GB, 72746008576 bytes
255 heads, 63 sectors/track, 8844 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x11e3119f

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          64      512000   83  Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2              64        8845    70528000   8e  Linux LVM

Disk /dev/mapper/vg_lal2server-lv_root: 34.4 GB, 34431041536 bytes
255 heads, 63 sectors/track, 4186 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mapper/vg_lal2server-lv_root doesn't contain a valid partition table

Disk /dev/mapper/vg_lal2server-lv_swap: 21.1 GB, 21139292160 bytes
255 heads, 63 sectors/track, 2570 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mapper/vg_lal2server-lv_swap doesn't contain a valid partition table

Disk /dev/mapper/vg_lal2server-lv_home: 16.6 GB, 16647192576 bytes
255 heads, 63 sectors/track, 2023 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/mapper/vg_lal2server-lv_home doesn't contain a valid partition table

These are all from the install hdd not the additional hard drives

modprobe a320raid
FATAL: Module a320raid not found.

lsscsi -v:

[0:0:0:0]    cd/dvd  TSSTcorp CDRWDVD TS-H492C DE02  /dev/sr0
  dir: /sys/bus/scsi/devices/0:0:0:0  [/sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:0/0:0:0:0]
[4:0:10:0]   enclosu DP       BACKPLANE        1.05  -
  dir: /sys/bus/scsi/devices/4:0:10:0  [/sys/devices/pci0000:00/0000:00:05.0/0000:01:00.0/0000:02:0e.0/host4/target4:0:10/4:0:10:0]
[4:2:0:0]    disk    DELL     PERC 5/i         1.03  /dev/sda
  dir: /sys/bus/scsi/devices/4:2:0:0  [/sys/devices/pci0000:00/0000:00:05.0/0000:01:00.0/0000:02:0e.0/host4/target4:2:0/4:2:0:0]

. lsmod:

Module                  Size  Used by
fuse                   66285  0
des_generic            16604  0
ecb                     2209  0
md4                     3461  0
nls_utf8                1455  0
cifs                  278370  0
autofs4                26888  4
ipt_REJECT              2383  0
ip6t_REJECT             4628  2
nf_conntrack_ipv6       8748  2
nf_defrag_ipv6         12182  1 nf_conntrack_ipv6
xt_state                1492  2
nf_conntrack           79453  2 nf_conntrack_ipv6,xt_state
ip6table_filter         2889  1
ip6_tables             19458  1 ip6table_filter
ipv6                  322029  31 ip6t_REJECT,nf_conntrack_ipv6,nf_defrag_ipv6
bnx2                   79618  0
ses                     6859  0
enclosure               8395  1 ses
dcdbas                  9219  0
serio_raw               4818  0
sg                     30124  0
iTCO_wdt               13662  0
iTCO_vendor_support     3088  1 iTCO_wdt
i5000_edac              8867  0
edac_core              46773  3 i5000_edac
i5k_amb                 5105  0
shpchp                 33482  0
ext4                  364410  3
mbcache                 8144  1 ext4
jbd2                   88738  1 ext4
sd_mod                 39488  3
crc_t10dif              1541  1 sd_mod
sr_mod                 16228  0
cdrom                  39771  1 sr_mod
megaraid_sas           77090  2
aic79xx               129492  0
scsi_transport_spi     26151  1 aic79xx
pata_acpi               3701  0
ata_generic             3837  0
ata_piix               22846  0
radeon               1023359  1
ttm                    70328  1 radeon
drm_kms_helper         33236  1 radeon
drm                   230675  3 radeon,ttm,drm_kms_helper
i2c_algo_bit            5762  1 radeon
i2c_core               31276  4 radeon,drm_kms_helper,drm,i2c_algo_bit
dm_mirror              14101  0
dm_region_hash         12170  1 dm_mirror
dm_log                 10122  2 dm_mirror,dm_region_hash
dm_mod                 81500  11 dm_mirror,dm_log

blkid:

/dev/sda1: UUID="bc4777d9-ae2c-4c58-96ea-cedb342b8338" TYPE="ext4"
/dev/sda2: UUID="j2wRZr-Mlko-QWBR-BndC-V2uN-vdhO-iKCuYu" TYPE="LVM2_member"
/dev/mapper/vg_lal2server-lv_root: UUID="9238208a-1daf-4c3c-aa9b-469f0387ebee" TYPE="ext4"
/dev/mapper/vg_lal2server-lv_swap: UUID="dbefb39c-5871-4bc9-b767-1ef18f12bd3d" TYPE="swap"
/dev/mapper/vg_lal2server-lv_home: UUID="ec698993-08b7-443e-84f0-9f9cb31c5da8" TYPE="ext4"

dmesg shows:

megaraid_sas: fw state:c0000000
megasas: fwstate:c0000000, dis_OCR=0
scsi2 : LSI SAS based MegaRAID driver
scsi 2:0:0:0: Direct-Access     SEAGATE  ST3146855SS      S527 PQ: 0 ANSI: 5
scsi 2:0:1:0: Direct-Access     SEAGATE  ST3146855SS      S527 PQ: 0 ANSI: 5
scsi 2:0:2:0: Direct-Access     SEAGATE  ST3146855SS      S527 PQ: 0 ANSI: 5
scsi 2:0:3:0: Direct-Access     SEAGATE  ST3146855SS      S527 PQ: 0 ANSI: 5
scsi 2:0:4:0: Direct-Access     HITACHI  HUS154545VLS300  D590 PQ: 0 ANSI: 5
scsi 2:0:5:0: Direct-Access     HITACHI  HUS154545VLS300  D590 PQ: 0 ANSI: 5
scsi 2:0:8:0: Direct-Access     FUJITSU  MBA3073RC        D305 PQ: 0 ANSI: 5
scsi 2:0:9:0: Direct-Access     FUJITSU  MBA3073RC        D305 PQ: 0 ANSI: 5

i.e. the 3 RAID Arrays Seagate Hitatchi and Fujitsu hard drives respectively.

FURTHER UPDATE

I have installed the megaraid storage manager console and connected to the server. It appears that the two CentOS installation hard drives are OK. The other 6 drives, one raid array of 4 and one raid array of 2 disks. The other drives are listed as (Foreign) Unconfigured Good.

share|improve this question
    
Please post the output of sudo fdisk -l and try modprobe a320raid –  Jure1873 Jun 19 '12 at 17:54
    
I don't get it. the 39320 is a SCSI U320 card. How can it be connected to SAS drives? Please post the output from lspci, lsmod and lsscsi too. –  wazoox Jun 19 '12 at 19:50
    
I think I have got confused, and the 39320 must have been connected to the tape drive (no longer in use). It must be on the PERC controller from dell. –  Quanano Jun 19 '12 at 21:05
    
Post the output of blkid –  MikeyB Jun 19 '12 at 21:15
add comment

migrated from serverfault.com Jun 20 '12 at 7:10

This question came from our site for professional system and network administrators.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.