Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been facing sound problem on my dell inspiron laptop since yesterday. It only plays sound when I plug in my headphone. I have 64-bit windows 7 installed.

I've already checked in sound, video and controllers driver's status which is showing "This device is working properly.". I tried restart, but that also not worked.

Does anyone know how can I solve this problem?

share|improve this question
Try Uninstalling and reinstalling the latest audio drivers. – nikhil Jun 20 '12 at 15:39
Ah! I faced this problem just few months ago and guess what my internal speakers were gone and have to change them. May be in your case its necessary that the speakers are dead but if the solution provided below doesn't work then I'm 100% sure that they have gone and time to change them. – avirk Jun 20 '12 at 16:10
up vote 3 down vote accepted

This happened to my laptop few years ago and It still exist. What has happened to your laptop is that the headphone pin has broken [or hopefully just stuck] and when you unplug your headphones, the computer still thinks there's a headphone connected.

You should replace the headphone pin (It's quite cheap) to fix the issue completely.

There are several "hacks" to temporary/luckily get it to work:


  2. You can edit registry settings to force disable headphone jack and output the sound through speaker.

    Press Start > Run > Type regedit > Choose My Computer > from menu select edit > find > Search for "ForceDisableJD" and press find. > once found change the value from 0 to 1. > restart

Please note that the above solution will disable your headphone jack and you'll have to change the value back to 0 in order to use it again. Good luck!

share|improve this answer
The setting "ForceDisableJD" might be missing, I used these links to find it: Realtek 1, Realtek 2, although I'm not sure I have a Realtek soundcard. No "Settings" entry, but GlobalSetting: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BF‌​C1-08002BE10318}\0007\GlobalSettings (0007 is the only one with subkeys). (to be continued) – Liviu Dec 27 '13 at 13:00
(continued) I manually added binary key ForceDisableJD with the value "01 00 00 00" and now my headphones are disabled. I'll see if this happens again (it used to happen not only after using headphones, but ... all of a sudden). I tried to restart the audio services with "ForceDisableJD" changed, to avoid the restart, but I didn't succeed to disable them again (without the restart). – Liviu Dec 27 '13 at 13:06
It still happens :(( ... after an hour or alike, no headphones implied. But it always works with headphones. – Liviu Dec 27 '13 at 13:57
+1. Solved the problem for me. Thanks Nima :) – Abdullah Leghari Dec 7 '14 at 14:50

I had a similar problem with my Macbook once, I solved it by plugging and unplugging the headphones multiple times, fairly rapidly (Of course, be careful not to break the socket or plug). There's a sensor inside which can get stuck, if it thinks there are headphones plugged in at all times then you will never get sound from your speakers.

It's not a particularly technical answer, but I think it might well be the solution you're looking for.

share|improve this answer
-1 for Voodoo!! – nikhil Jun 20 '12 at 15:39
It worked. It's a suggestion, what exactly have you provided? – arpz Jun 20 '12 at 15:56
Good for you if it worked. – nikhil Jun 20 '12 at 15:58
Yes, and it's also one of the suggestions in the link in the uprated answer above. – arpz Jun 20 '12 at 16:05
Please, I don't wish to argue with you. I think it's a poor answer hence the downvote. – nikhil Jun 20 '12 at 16:09

If it started a couple of days back, it's most likely a problem caused by the recent Flash update (11.3). See the details here:

You will need to revert back to Flash 11.2 to solve the problem (meanwhile they fix the problem on 11.3).

share|improve this answer
The asker is seeing this issue for all audio, not just flash. This question was marked as solved 8 days ago anyway. Why are you even posting? – VBwhatnow Jun 28 '12 at 12:09

The "Voodoo" kind of solution, as mentioned above (that means to connect and disconnect an audio device many times), actually worked for me many times when I had similar problems. You could also try the "Disable front panel jack detection" or something similar whenever it gets stuck, so you can have your built in speakers working back to normal.

share|improve this answer

You must log in to answer this question.

protected by bwDraco May 16 '15 at 6:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .