Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

All of this was working fine on Windows XP Professional SP3. I just installed Windows 7 Professional 64-bit and it doesn't work anymore.

My video card is an NVIDIA GeForce 8500 GT. I have a plain old VGA cable running to my primary display (19" LCD monitor). I have an S-video cable running to a Philips RF Modulator (model ph61159) pictured here:

Philips RF Modulator (model ph61159)

Philips RF Modulator (model ph61159)

From the "TO TV" coax jack on the back of the RF modulator, I have a coax cable running to a splitter that sends the signal to all of the TV's in my house. So when I wanted to watch a computer video on one of my TV's, my process was:

  1. Enable the secondary display.
  2. Drag the video to the secondary display.
  3. Turn one or more of my TV's to channel 3 or 4 (depending on the RF modulator's front switch)
  4. Enjoy.

See the little red LED on the front of the RF modulator? It's supposed to turn solid when I have the secondary display enabled. It's off otherwise.

Before installing Windows 7, the light would turn on as soon as I switched on the secondary display in either Windows Display settings or using the nVidia control panel (either way worked).

After installing Windows 7, the light will blink a little bit when I switch on the secondary display in either Windows Display settings or using the nVidia control panel, but goes off and ultimately I have nothing sent to my TV's.

Here is a video of what is happening.

This is a show stopper for me. I will reinstall Windows XP if I can't get this fixed. Is there anything I can do?


I had my wife watch the tv while I turned on the secondary display and she saw windows on the tv for a moment, but then it disappeared.


I changed the refresh rate for the TV from 29hz to 30hz and that gives me a solid red LED on my RF modulator, but the TV has a black & white picture that isn't still (moving from top to bottom very quickly.) I haven't found any more advanced settings yet. Any ideas?


I noticed that when you change the tv's refresh rate to 30hz and press apply, the refresh rate changes to 25hz, which wasn't in the list of options before.


At some point I had a still black & white picture on the TV, but I have no idea which combinations of nvidia control panel settings and windows display settings got me there.

share|improve this question
up vote 2 down vote accepted

Have you tried the "My display is not shown..." option on the page that you showed in your video? There is an option to force detection of TVs that might help.

share|improve this answer
I did try that even though my display is shown (it's talking about the checkbox that says TV). If I disconnect the sVideo cable, I lose that checkbox. – Ronnie Overby Sep 19 '09 at 22:48
It was worth a shot - my only other recommendation would be to make sure your resolution and refresh settings are set correctly for the TV. – Chrisbux Sep 19 '09 at 22:54
I think your resolution should be set to 720x480, interlaced. I'm not sure if the refresh rate should be 30hz or 60hz since the signal is interlaced. – Chrisbux Sep 20 '09 at 0:16

Hey there, I just stumbled across this page while searching for a similar issue. I've actually had the problem you're talking about in the past; it was with me for almost a year before I found a solution in another forum. My problem wasn't exactly the same, but extremely similar. It started happening after I bought a 9800GT to replace an older 7600. Once installed, I couldn't get the damn thing to do a secondary display on my CRT television, which it used to be able to do with the 7600. Instead, it would flicker for a second then go to full-in black and white fuzz. Surprisingly, I also use the exact same RF modulator that you use.

I think my solution may work for you, because I think the issue has to do with the drivers, not Windows 7 or my new video card specifically. In my case, I got advanced drivers because of the new video card, and in yours, they may be advanced because of the upgrade to Windows 7. In any case, someone on another board mentioned that when you click "okay" to start the secondary display, the video card now sends a resistance check to ensure that the signal will work correctly before actually sending the full display. The problem lies in that little RF modulator, which apparently interferes with the resistance check, causing the video card to think the signal's no good, and to then turn off the display. In this case, you might see a flickering second or so of display before it shuts off. That's what I had.

The solution is a bit of a pain, but it works for me, and there's no software workaround that I've found yet. You'll need a "neutral" s-video input: any other device you can plug your s-video cable for your secondary display into. I use a powered-off laptop. Go to the nVidia control panel and go to "set up multiple displays" or whatever the name of the screen is where you can turn your secondary display on and off. With your connection to your television intact, activate the secondary display and confirm "yes, keep these changes." It won't work, fine. Now turn the secondary display off again and confirm. Now unplug your s-video cable from the RF modulator and insert it into your "neutral" s-video port (again, I just stick it into my powered-off laptop). Now click to reactivate the secondary display and confirm. Finally, unplug the s-video cable from your "neutral" port and plug it back into your RF modulator. This works for me. It's a pain, yes, but it works, and I only use my secondary display when I watch movies, so it's only once in a while. If you have a problem with the secondary being only black and white, it's likely a problem with your television's input, which you need to set to the correct s-video mode: I clicked to change the "input" setting on my remote and this worked.

On a side note: every single time nVidia does anything new (new drivers, new hardware, new software) they cause a problem for users who don't have the latest cuttin-edge technology. I drives me crazy, and I loathe updates, because I know I'll have to spend an hour or so figuring out how they've screwed me over again because I don't have a fancy plasma TV or whatever. XP with the old 7600 worked like a charm for my CRT television. Windows 7 with my 9800 is a nightmare.

share|improve this answer
I bought an xbox; problem solved. – Ronnie Overby Feb 26 '10 at 5:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .