Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have some problem installing Firefox 13.0.1 (latest from official site) on my fresh Debian 6.0.5 installation.

What i did:

Removed iceweasel, unzipped firefox*.tar.bz2 into /opt/

Created symlink /usr/bin/firefox pointing to /opt/firefox/firefox

But when trying to open from terminal with firefox i get:

bash: /usr/bin/firefox: No such file or directory

Also doubleclicking on the firefox executable inside /opt/firefox/, doesn't open, no errors, just nothing!

How can i have firefox working? Thank you!

share|improve this question
up vote 1 down vote accepted

I got the exact same error message when trying to run a 32bit build of Firefox in a 64bit version of Debian. Unfortunately, Mozilla seems to only provide 32bit versions on their download page.

You have 2 options:

  • get a Mozilla 64bit build from their ftp server: ftp://ftp.mozilla.org/pub/firefox/releases/latest/linux-x86_64/en-US/ But be aware that there might be problems with extensions and plugins which have been designed for the 32bit version.
  • use the 32bit version with compatibility libraries. You just have to do an sudo apt-get install ia32-libs ia32-libs-gtk. After this, your already installed 32bit version should work.

I went with the second approach and everything worked out fine.

share|improve this answer

Download Firefox. Then type the following commands as root:

mv firefox*.tar.bz2 /opt

cd /opt

tar -xvjf firefox*.tar.bz2

ln -s /opt/firefox /usr/local/firefox

ln -s /usr/local/firefox/firefox /usr/local/bin/firefox

rm firefox*.tar.bz2

Firefox can now be run as normal user with command firefox or /usr/local/bin/firefox. In Gnome, you can add Firefox to the application menu as follows:

  1. right-click on the Applications menu
  2. select "Edit menus"
  3. click on "Internet"
  4. select "New item"
    • type "Application"
    • name "Firefox"
    • command /usr/local/bin/firefox
  5. To add the Firefox icon to the menu, find it in /opt/firefox/icons/mozicon128.png
share|improve this answer
    
This works out only if you download the correct version of firefox (64bit binaries for 64bit Debian installs). See my answer for details. – severin Oct 23 '12 at 8:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .