Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

[Note 11/2014: I updated the question title to better reflect answers given.]

I installed the release preview of Windows 8, which comes with Internet Explorer 10.

IE10 has been endowed with a spell checking Feature, which is active while I write this text.

As a matter of principle, I disable spell checking anywhere I go. I simply hate spell checking. I know better than the spell checker. (And when not it doesn't matter.)

This is all the more annoying as I write in several languages and the spell checker only does one language (German, in this case), and then even in the new and wrong spelling, not in the old an true one. How can I disable this?

share|improve this question
    
There is already an IE10 tag. I've retagged your question. –  user3463 Jun 20 '12 at 22:41

4 Answers 4

Windows 8 has a system level spell checker. The only way to disable it is to kill the process.

enter image description here

http://schmitta.wordpress.com/2011/09/27/windows-8-developer-preview-disable-spell-checker/

share|improve this answer
    
Thanks! Killing is the process is an option, but not the best one. At the bottom of the blog post you referred to, there is an answer by one Michal Altair Valášek who points at the proper solution, which I have detailed in my answer. –  Lumi Jun 21 '12 at 10:08
up vote 8 down vote accepted

Update for Windows 8.1 as of 11/2014:

Since I've been using StartIsBack and Glass8, I've been reconciled with Windows 8 and 8.1, in as much as it now looks as nice as Windows 7. (Note: Talking about real PCs here, not ARM devices faking to be PCs.) But every now and then, TIFKAM ("The Interface formerly known as Metro") rears its flat head, like when - and that brings me back to this question - you want to disable the horror that aggressive and obtrusive spell checking represents for users who've learned proper spelling back in their schooldays, and who may happen to converse in more than one language.

So, my first try on this new PC was to check the control panel (the proper one), thinking that meanwhile Microsoft should have gotten their act together and integrated the spell checking among the language settings, which seems like the obvious choice. But no, there's nothing there. Checked some other CP entries like accessibility, region, Spracherkennung (literally "language recognition"), but no, nothing there either.

Okay, I'd have to go check the Metro control panel. Shudder. How to get there? Ah right, Windows+C ("charms", whatever that is), and then "Settings", and then "Change PC Settings" (translated from German). The dreaded fullscreen TIFKAM settings "app" appears. Guess what, it has an entry "Zeit und Sprache" ("Time and Language") - now this must be where I'd find spell checking, wouldn't I? (By the way, shouldn't that have been "Time and Space"? Guess it's all about educating users by disappointing their expectations.) Alas, no. After clicking around in a confused, annoyed and somewhat random manner I found the place. It's under "PC und Geräte > Eingabe", probably something like "PC and Devices > Input".

Disable spell checking in the TIFKAM control panel

I hate to say it, but when I'm in the Mac OS X control panel, I never struggle to find things. Why is it so hard to file language related settings under "Language"?

I very much hope they reintegrate all the settings in the TIFKAM control panel into the proper Windows control panel. And then keep the TIFKAM stuff for ARM only. Or rather, have one more setting in the control panel, for TIFKAM itself, to be switched on or off, as best suits the hardware.

Original answer from Jun 21 '12:

The proper solution is to disable spell checking (Rechtschreibprüfung) in the System Settings (Systemsteuerung) going via the new Metro Settings and clicking on "Allgemein". In English, that pane appears to be labeled "General". See screenshot below.

Disable spell checking / Rechtschreibprüfung aus

Note about old and new spelling in German: Wer die Prüfung behalten möchte, aber die alte Rechtschreibung lieber mag, der kann dies in folgendem Pfad in der klassischen Systemsteuerung einstellen:

Systemsteuerung\Zeit, Sprache und Region\Sprache\Sprachoptionen

enter image description here

share|improve this answer
    
this answer was not helpful, I don't speak german. –  Ender Oct 11 '13 at 23:10

To disable spelling correction in Internet Explorer 10 on Windows 7:

  1. Go to Tools → Manage add-ons

    screenshot 1

  2. Under Spelling Correction, uncheck "Enable spelling correction"

    screenshot 2

share|improve this answer

Without changing system files again, a third-party program that did the job for me is WinSpell: http://www.winspell.com/home

All official and standard and normal ways of disabling spell correction did not work. (But it seems many people do not understand what I just wrote here.) And I did not feel like messing around with system files again as these are circuitous to edit.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.