Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am changing from Windows XP to Windows 7. One thing I cannot stand about Windows 7 is that whenever you mouse over files in Explorer (or other file-browser), it highlights the files with a semi-transparent block.

This is nice, but I want to be able to double-click on the white area background of the directory, and I can't do this with the highlighted selection always there. The hovering-block is always in the way of the background - especially if there are a lot of files in the directory.

(I don't even know what that hovering-block is called; if someone enlightens me, I'll re-title my post)

Is there any way to get the file selector to work like XP?

[edit]

Well, after using Windows 7 now, for several months, I still haven't figured out how to get rid of this!

[later...]

Okay, I still have not found out how to resolve this.

share|improve this question
    
For each view (Icons, List, Detail, etc), there should be a margin of click-able whitespace on the left of the pane. This is where I right-click if I want to bring up the context menu for the current directory. –  iglvzx Jun 21 '12 at 0:34
    
I know what you mean BGM, it is almost always more annoying than novel. It is particularly frustrating when you have hundreds of photos in a folder in large-thumbnail—mode and you are trying to select multiple files. –  Synetech Jun 21 '12 at 1:20
2  
@iglvzx, that margin is not nearly large enough to be conveniently clickable, certainly not when compared to the space around files in XP. –  Synetech Jun 21 '12 at 1:21
    
Can you elaborate on what double-clicking the white area does for you? It does nothing in my install. Also, right-click anywhere there is no text or picture will bring up the same context menu as the one that you get when right-clicking on a blank area (even if the semi-highlight hover indicator is visible). –  horatio Dec 20 '12 at 21:32
    
In XP it only selected to the length of the text. The hover-block is a newer Windows "feature", and it persists even into the use of other file-managers - like Q-Dir or FreeCommander. In those programs, I can go to the parent directory by double-clicking on the background; the hover block gets in the way. That is the utility of the thing, anyway. If you left-click on the hover-block, the file receives the click instead of the directory background. –  BGM Dec 20 '12 at 23:46
add comment

3 Answers

Go to Registry Key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Look for Value Name: ShowInfoTip Data Type: REG_DWORD

If not present Create the Value Name [ShowInfoTip]

Modify the Value Data to 0 for ShowInfoTip Disabled

share|improve this answer
    
Your hack is for the tooltip popup, not for the selection block that appears when you hover over a file. –  BGM Aug 13 '12 at 13:30
add comment

You can shrink the selection box to the name column by disabling Full Row Select. Unfortunately, this has been made difficult in Windows 7: the article at http://www.winhelponline.com/blog/disable-full-row-select-explorer-windows-7/ attempts to shed some light on the issue.

share|improve this answer
    
I shrunk that a long time ago, actually. I want to get rid of it comletely, so that it works like XP. –  BGM Aug 13 '12 at 13:29
add comment

My Computer> Organize (in the top-left area)> Folder & Search Options> View Tab> Show Pop up descriptions for folder and desktop items (turn it off).

share|improve this answer
    
In Windows 7 it is called "Computer" and there is no command called "Organize" at all. But if you open a folder and go to "Folder Options > View Tab" and look for "Show pop-up description for folder and desktop items" you would find it already unchecked on my system because the issue doesn't concern the little tooltip popups. It concerns the translucent sector box that appears over files when you move the cursor. I'm sure my question is clear! –  BGM Dec 31 '13 at 14:44
    
I didn't think it mattered that it is no longer called 'My Computer' but rather Computer. 2. There is a command called Órganize' in the top left corner of the 'Çomputer' which I'm seeing right now (I'll try to attach screen shot). 3. I did understand wrongly. 4. Solution is in the 'Folder Options> ''Click Items as Follows'' (almost in the middle of the General tab)> Double Click (rather choosing 'Single Click') to open an item. 5. Sorry that you reduced my (answer's) rating, even if didn't help. –  zopfan Jan 2 at 8:50
    
It wasn't a matter that it didn't help. It wasn't a solution to the problem described - and is the same answer given by others. It's nothing personal, it's just how SE works. –  BGM Jan 2 at 15:00
    
OK no offense taken then. 2nd: Now tell me if my 2nd (posted 2 days ago) solution solves your problem or not. And why so? –  zopfan Jan 4 at 14:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.