Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have win 7 64 bit with zone alarm 10. Although zone alarm says it gives permissions to access the internet, eclipse fails to reach the internet. If I shut down zone alarm, eclipse can update fine - pretty conclusive. How do I configure zone alarm to allow eclipse to update?

share|improve this question

migrated from stackoverflow.com Jun 21 '12 at 7:34

This question came from our site for professional and enthusiast programmers.

1  
This is still a problem with Indigo and ZoneAlarm 10.1 I've looked at the "program control" -- Java, Eclipse, and other obvious programs work. For contrast curl works fine under firewall protection. My expectation is that the problem like within Java7 because the updates work with Java6 and ZoneAlarm. The tip from the Android user might work if you use the Android SDK but not for Eclipse. –  will Jun 20 '12 at 0:08
    
Great point. I have asked a moderator to re-title the issue. –  Android Addict Jun 20 '12 at 15:45

1 Answer 1

up vote 1 down vote accepted

I found the two-step answer: In ZoneAlarm go to firewall settings and set Public Zone security to Medium and add the application 'SDK Manager.exe' to the Application Control Settings and allow inbound and outbound internet access.

The 'SDK Manager.exe' application is in the Android SDK folder that you installed to.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.