Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with my Linux installation.

It seems that the KDE code that deals with directory windows is extremely slow (on both Dolphin and Konqueror). This happens both when I click on a directory icon and when I want to open/save a file from many KDE applications. The time the window takes to open can be one minute or more. The same happens when I right click on an icon.

Looking at the CPU usage, this is very low (less than 10%).

Am I the only one with this problem, or is it well known and maybe already fixed?

Consider that I cannot update to a more recent version of OpenSuse.

Thank you,
Pietro

Configuration:
Linux version: OpenSuse 11.4
KDE 4.6.0
System: DELL Precision T3500 - Intel Xeon
Home directory mounted on a remote drive. <-- could this be the reason?

share|improve this question

migrated from stackoverflow.com Jun 21 '12 at 9:14

This question came from our site for professional and enthusiast programmers.

    
Have you tried to turn off Nepomuk/Strigi? –  Dragon Jake Jun 21 '12 at 8:20
    
@DragonJake: Nepomuk and Strigi seem to be core parts of KDE. Is it possible/worth turning them off? Is it possible to modify some settings to make them less resource-hungry? Even if resources are not a problem after all... –  Pietro Jun 21 '12 at 8:50
    
many users were/are complaining about uselessness and slowness of these KDE components. Appropriate settings could be found in Personal Settings → Desktop Search. Try to turn them off completely first to see if they were the problem. –  Dragon Jake Jun 21 '12 at 8:55
    
I disabled both Nepomuk and Strigi. Nothing changed... –  Pietro Jun 21 '12 at 9:07
    
It was just a guess. Let's try something else, rename your .kde/.kde4 directory and restart the X server. New KDE directory with default settings should be created. Does the problem still occur? –  Dragon Jake Jun 21 '12 at 9:12
show 2 more comments

2 Answers

In my case, I had this problem (though not with such extreme slowness) and it was related to graphics acceleration not working. Are desktop effects disabled in KDE settings? If not, disable them.

share|improve this answer
    
No, it does not depend on desktop effects. I disabled them with no improvement. –  Pietro Jun 26 '12 at 21:21
add comment

I had the same issue, but intermittently.

Turns out the slow down only happens when there's a disc in my DVD drive.

For some reason, KDE re-reads the optical drive every time you switch to the file manager.

share|improve this answer
    
Not my case, unfortunately. –  Pietro Jun 22 '12 at 9:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.