Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to limit the download speed for some temporary time and then make it unlimited again. Scenario, I dont want the Transmission to take all bandwidth while surfing for 5 minutes. I wish to use Transmission CLI because I want to automate the whole process.

This is how I add the torrent file.

transmission-cli ~/Downloads/572403AA8726F9519C3897766B32F56C421681A4.torrent

But to limit the download speed. First I have to do CTRL+C to pause the torrent And then

transmission-cli -d 30 ~/Downloads/572403AA8726F9519C3897766B32F56C421681A4.torrent

to limit the speed.

Does anyone have a cleaner solution to this.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Instead of using transmission-cli directly, run Transmission as a RPC server. transmission-daemon was created for this, but the GNOME Transmission app will work too.

$ transmission-daemon -g ~/.config/transmission

(An useful option is --watch-dir ~/Downloads, which automatically adds all *.torrent files found.)

You'll be able to use transmission-remote to control the server – add torrents, pause/resume, adjust speed:

$ transmission-remote --add ~/Downloads/*.torrent    (-a ...)
$ transmission-remote --downlimit 30                 (-d 30)
$ transmission-remote --no-downlimit                 (-D)

Transmission also has an "alternate speed" mode:

$ transmission-remote --alt-speed-downlimit 30       (-asd 30)
$ transmission-remote --alt-speed                    (-as)
$ transmission-remote --no-alt-speed                 (-AS)
share|improve this answer
    
after transmission-daemon and then transmission-remote --add ~/Downloads/*.torrent it gives the error. Unexpected response: <h1>401: Unauthorized</h1>Unauthorized Useroded –  Vincent Vettukal Jun 21 '12 at 11:08
    
Try killing the daemon and restarting with -T option. –  grawity Jun 21 '12 at 11:10
    
Did that, killed all process with the Transmission too. Didnt work out. Going to restart the computer and try again. –  Vincent Vettukal Jun 21 '12 at 11:17
    
Tried it after restart. Still giving the same error. Maybe cli is default port is not the one on which Daemon is working –  Vincent Vettukal Jun 21 '12 at 11:33
    
stackoverflow.com/questions/6843978/nice-bittorrent-tracker-api Got this link. Talks about authorization to use Daemon. But could not set up the Web Client from GUI too... –  Vincent Vettukal Jun 21 '12 at 11:55
add comment

The only way to set a download limit is to declare it at first using the -d option. You can't temporarily set a downlimit while downloading without stopping and starting the process again.

If you can, use transmission-gtk which has the Alternative speed limit option and you can activate/deactivate it by a button.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.