Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried to install Skype on CentOS 6.2. I downloaded Skype's rpm package from here and tried this command to install – but it's giving an error like this:

[root@localhost Downloads]# rpm -ivh skype-4.0.0.7-fedora.i586.rpm 
error: Failed dependencies:
    alsa-lib >= 1.0.23 is needed by skype-4.0.0.7-fc16.i586
    libstdc++.so.6(GLIBCXX_3.4.15) is needed by skype-4.0.0.7-fc16.i586

So I tried this command:

[root@localhost Downloads]# rpm -ivh --nodeps skype-4.0.0.7-fedora.i586.rpm 
Preparing...                ########################################### [100%]
   1:skype                  ########################################### [100%]

The Skype icon will appear in Applications » Internet » Skype, but when clicking the icon nothing's happening.

So I installed libstdc++6-4.7.0-0.6-mdv2012.0.i586.rpm with this command:

[root@localhost Downloads]# rpm -ivh libstdc++6-4.7.0-0.6-mdv2012.0.i586.rpm 
warning: libstdc++6-4.7.0-0.6-mdv2012.0.i586.rpm: Header V3 DSA/SHA1 Signature, key ID 26752624: NOKEY
Preparing...                ########################################### [100%]
    file /usr/lib/libstdc++.so.6 from install of libstdc++6-4.7.0-0.6.i586 conflicts with file from package libstdc++-4.4.6-3.el6.i686

It's still not working.

share|improve this question
    
Did you try running it from a terminal? –  Ignacio Vazquez-Abrams Jun 21 '12 at 12:02
    
yes... it is giving the error like this [suraj@localhost ~]$ skype skype: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by skype) –  max Jun 21 '12 at 12:10
    
Check your formatting please, next time indent code using Ctrl-K. –  slhck Jun 21 '12 at 12:32
    
Maybe you should have listened when rpm told you there was a problem then. –  Ignacio Vazquez-Abrams Jun 21 '12 at 12:35
add comment

1 Answer

up vote 1 down vote accepted

Change root user

su -

Install Needed Dependencies

yum install alsa-lib.i686 fontconfig.i686 freetype.i686 glib2.i686 libSM.i686 libXScrnSaver.i686 libXi.i686 libXrandr.i686 libXrender.i686 libXv.i686 libstdc++.i686 pulseaudio-libs.i686 qt.i686 qt-x11.i686 zlib.i686

Download Latest Skype Static Package

cd /tmp

wget http://www.skype.com/go/getskype-linux-beta-static

Extract Skype

mkdir /opt/skype

tar xvf skype_static* -C /opt/skype --strip-components=1

Create libtiff.so.4 link

cd /usr/lib

ln -s libtiff.so.3 /usr/lib/libtiff.so.4

Create Launcher, Link icons, lang and sounds

ln -s /opt/skype/skype.desktop /usr/share/applications/skype.desktop

ln -s /opt/skype/icons/SkypeBlue_48x48.png /usr/share/icons/skype.png

ln -s /opt/skype/icons/SkypeBlue_48x48.png /usr/share/pixmaps/skype.png

touch /usr/bin/skype

chmod 755 /usr/bin/skype

Open /usr/bin/skype with text editor and add following content:

#!/bin/sh

export SKYPE_HOME="/opt/skype"

$SKYPE_HOME/skype --resources=$SKYPE_HOME $*

Start Skype

From command line use skype command

skype

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.