Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows 7 and ESET SMART SECURITY 5 .

Today I wanted to update my computer using Windows Update but it does give me error :

Error(s) found:

Code 80244004        Windows Update encountered an unknown error.

My System Info :

Sony Vaio EA2gfx , Ram : 4GB DDR2 , CPU: Intel Core i 5

I checkd out this links but they didn't help : http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_update/while-updating-i-am-getting-the-error-code/0b9b756c-5b6e-4571-838e-f90c48a4e00c

https://www.calguns.net/calgunforum/showthread.php?t=583860

http://www.sevenforums.com/windows-updates-activation/235807-windows-update-error-80244004-a.html

Please help me, thanks.

share|improve this question

migrated from stackoverflow.com Jun 21 '12 at 13:01

This question came from our site for professional and enthusiast programmers.

    
Are you running Eset or Malwarebytes?? –  Akshat Mittal Jun 21 '12 at 13:04
1  
    
Yes I'm using ESET –  Hamidreza Jun 22 '12 at 5:46

2 Answers 2

up vote 2 down vote accepted

My problem solved by changing some settings in ESET SMART SECURITY : In ESET I went to :

Setup > Enter advanced setup... > Web and email > Web access and antiphishing protection > HTTP, HTTPS

then in HTTPS scanner setup tab and in HTTPS filtering mode tab :

check the Do not use HTTPS protocol checking

Then the problem solves

share|improve this answer

I was not totally comfortable with the Eset change suggested, so I called Eset. They did not recommend this change - said they had another call on this and were looking at solutions.

However, I mentioned another problem I have been having accessing HTTPS sites in Firefox - I thought they were Firefox Tab-Group issues. Amazingly, the Eset person said they have a fix for this one and it fixed my Windows update problem:

First, close all apps that might be accessing the web using HTTPS.

  1. Open Eset Smart Security (I have 5.2.9.1 and this all may have started when I upgraded recently).
  2. Push F5 key
  3. Expand Web and Email
  4. Expand Protocol Filtering
  5. Click on SSL
  6. Select Do not scan SSL protocol
  7. Click OK
  8. Try Microsoft Update again - should work - mine did!
share|improve this answer
    
This just repeats what the accepted answer says. –  Ramhound Jun 28 '12 at 15:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.