Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use NaturallySpeaking a lot, and it's a great program, but it's very processor and memory intensive. As long as it's being used, it works fine, but if I tab away to another program for five minutes and then try to come back to NaturallySpeaking the computer churns away for about 30 seconds or a minute before it starts working again. It's really annoying. It makes NaturallySpeaking virtually unusable for intermittent use.

I'm assuming this is because when I tab to another program Windows reallocates the memory that was previously used for NaturallySpeaking and gives it to some other program. Is there a way to prevent this? Can I make sure that NaturallySpeaking ALWAYS has the memory it needs? I've got 4 GB of RAM, so it's not like I'm running out of it.

share|improve this question

4 Answers 4

I am not sure how well it will work and if it is just not a problem with the software, however to change priority of programs:

  1. Open task manager.
  2. Go to the processes tab.
  3. Right click on the program.
  4. Go to the Priorities Sub Menu
  5. Select a higher priority

alt text

share|improve this answer

It doesn't sound like a CPU problem, but rather a memory problem : NaturallySpeaking being swapped out of memory and taking time to swap in again. You can test this hypothesis using Task Manager:

  • Open Task Manager at a time that you're experiencing this problem
  • First click on the Performance tab and look for anomalies. You might even take a screenshot of it and edit the image into your post.
  • Click on the Processes tab
  • Select menu View / Select Columns...
  • Place a check-mark next to "Memory - Working Set" and click OK
  • In Processes view you will now have a column by that name. Click on it twice, to sort by descending order, and report to us which processes (if any) are using an excessive amount.

Although with 4GB of memory you shouldn't be experiencing such problems, it might be that NaturallySpeaking is somehow parametered to using more memory than you have (the maximal amount that can use all the applications in the computer together is 2GB, the rest being used by Windows).

share|improve this answer

In control pannel->system->advanced_system_settings->Advanced_performance_settings->Advanced->processor_scheduling

There is a setting programs or background services. This affects the scheduler policy. Setting background services may improve things ( and it may not ).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.