Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using FoxTester to run firefox 3.6 to test my development site on non-html5 browsers.

It used to work fine for week until suddenly when try to launch 3.6 it will try to install an update (presumably firefox 16), but fails. As a result I cannot launch 3.6 at all.

How do I stop firefox from running auto-update?

I had a look at the mozilla support site here and seen many other forums suggesting the same. The thing is though that I cannot get to those settings as I cannot launch firefox 3.6 to disable auto-update as the auto-update prevents me from launching it.

Is there a configuration file where I can disable auto update or a launch parameter?

share|improve this question
    
Why don't you simply install an even earlier version? You could always compile Firefox 3.6 yourself and disable the check. –  Ramhound Jun 22 '12 at 11:13
2  
@Ramhound wow! compile firefox, that's overkill –  vikki Jun 22 '12 at 13:39
    
@Ramhound well I was already struggling to find a version as old as 3.6 and I don't think what compiling would be necessary. –  d_inevitable Jun 22 '12 at 22:52

1 Answer 1

up vote 2 down vote accepted
  • Look in your profile directory.
    (Where your profile directory is, depends on your operating system and version. Note: it might be in a hidden directory).
  • Open the file prefs.js
  • If it has a line saying
    user_pref("app.update.enabled", true);
    change the true to false.
  • Otherwise, add a new line saying
    user_pref("app.update.enabled", false);
    Note: the lines probably need to be in alphabetical order, so make sure you insert it in the right position.

Hope this helps!

share|improve this answer
    
+1 for teaching me something new. –  Nima Jun 22 '12 at 13:37
    
Well, it is a last resort. Normally it's not recommended to edit the prefs.js directly (since you can change all the prefs by going to about:config) but if you can't start up the browser because of a setting that needs to change, you can do that. –  Mr Lister Jun 22 '12 at 13:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.