Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Under the manage search engines section in preferences, I deleted the original Google search engine and added a new one with the same "URL" string. When I type in the Omnibar, search works fine however it fails to autocomplete the word. How should I remedy this?

share|improve this question

As far as I know, there's no way to manually restore the default Google search with all its features.1

However, you can delete the configuration file that contains user-defined searches and let Chrome recreate it.

Steps

  1. Close Chrome.

  2. Locate your profile's Chrome folder.

    Windows 8, 7 and Vista:

    %LOCALAPPDATA%\Google\Chrome\User Data\Default
    

    Windows XP:

    %USERPROFILE%\Local Settings\Application Data\Google\Chrome\User Data\Default
    

    Linux:

    ~/.config/google-chrome/Default
    

    Mac OS X:

    ~/Library/Application Support/Google/Chrome/Default
    

    If you're not using the default profile, replace Default with your profile name.

  3. Move the files Web Data and Web Data-journal elsewhere, so you can restore them in case their absence causes unexpected problems.

  4. Reopen Chrome. If you use a Google Account, sign in.

  5. Select the restored default Google search in Manage search engines and make sure the option Enable Instant for faster searching is checked.


1 The default Google search doesn't appear in the Web Data like user-defined searches. Selecting the default search modifies the properties "instant_url" and "suggest_url" of "default_search_provider" in the Preferences file. Even modifying those properties manually doesn't have the desired effect, since Chrome removes them on restart.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .