Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I would like to know how we can modify the settings of the Google Search Engine used in Internet Explorer 9.0 to force to use a specific language. Our problem is the following: as it uses geolocation by default, and we are in Switzerland, it takes the first of the official languages this is Swiss-German. However, we are located in Geneva where French is the official language. Furthermore, as most of our users speak English, we would like to force the language to be English and not Swiss-German.

Does anybody know how to achieve this ?

Thanks alot,


share|improve this question
The only way I know to change the language options of a Google is through the Google Profile itself. – Ramhound Jun 22 '12 at 12:43

2 Answers 2

Go to this page then you'll not have the problem.
Goggle -> advance search -> Search Settings -> languages

share|improve this answer

Although this is an old question and the other answer doesn't seem to grasp what you are apparently trying to do, I may have an answer that works.

Although I am otherwise unsure if you have changed your IE to a newer version, nor if you are on Windows 7, XP or something else, the following works on Windows 7 - Internet Explorer 11 and apparently works on Internet Explorer 9 and 10. I am unsure about its use in Edge.

Try adding the following to your registry (copy the text and save it into a text document. Save the document as [name].reg).

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchScopes\{3088BE79-CDC4-43F9-BB03-CFD2FC43B5C9}]
"DisplayName"="Google Switzerland (English)"
"FaviconPath"="C:\\Users\\[localuser]\\AppData\\LocalLow\\Microsoft\\Internet Explorer\\Services\\search_{3088BE79-CDC4-43F9-BB03-CFD2FC43B5C9}.ico"

Two things can prevent this from working.

  1. For whatever reason Registry Editor doesn't automatically change the [localuser] in the FaviconPath item into your computers username. This can be remedied by changing the [localuser] portion of the path to your PC Username.
  2. For whatever reason your computer doesn't like the {3088BE79-CDC4-43F9-BB03-CFD2FC43B5C9} string. Due to the way the registry sets these numbers (by using your username and the time/date as a seed) there may be some reason this particular number doesn't work for you.

- ! Problem Resolution ! -

If you are capable and comfortable with changing registry settings then go to HKCU\Software\Microsoft\Internet Explorer\SearchScopes\ and look for the entry that has your existing Swiss-German entry (the name in DisplayName will match the name you select under Manage Add-Ons > Search Providers). Replace the entries with ones from the Registry Entry above - In particular, the URL value.

Another way of doing this is to copy the key name for the entry (Right Click on the Key name eg.{27YB9U6S-...} > Select [Rename] > Right Click and Copy / Press [CTRL] + [C] and Paste it in the above Registry Entry (Under the Key Path and the Favicon Path {} sections). From there, running it as a .reg should set it properly.

If you wish to make this change for all users of the PC (not just the active one) change the key path from

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchScopes\{3088BE79-CDC4-43F9-BB03-CFD2FC43B5C9}


HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\SearchScopes\{3088BE79-CDC4-43F9-BB03-CFD2FC43B5C9}

When you do a search from the URL Bar in IE 9 - 11, it will now search under Google CH (English results).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.