Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Alright, before I begin I want to clarify some points so no one wastes their time giving solutions that have already been addressed and haven't worked:

  1. I am aware that this is a common error (0x80070570) on Dell machines.
  2. I have changed the settings in the BIOS as suggested by both Microsoft and Dell forums i.e. changed the drive settings from AHCI to ATA.
  3. The BIOS version shows as A12.
  4. The processor is 32 Bit.
  5. It is a clean install on a Dell XPS M1330 machine. There is no other Operating System on it.
  6. The ISO file used is the same one used to install the operating system I'm on right now and it was downloaded from the official Microsoft website. It runs on every other computer BUT the Dell.
  7. I'm trying to install Windows Ultimate 32 bit.
  8. I have checked the Ram and there is no problem whatsoever with the hardware.
  9. The computer was already running a Windows 7 Ultimate on it when I bought it but I had to uninstall it because it was a pirated version and I wanted to install the genuine one on it.
  10. I have tried to only install Windows through my USB since I don't have a working DVD-Drive on me right now (that's another problem but will worry about it on another thread).

So...

  1. I'm lost right now. Every time I start it stops at 7%. I'm guessing the following might be wrong:
  2. The data transfer between the USB and the HDD isn't doing alright, and it stops at 7%. But if that's the case, then how can it boot from the USB and also copy upto 7% in the first place?
  3. If the USB is the problem, and seeing that I do not have a working DVD drive, can I install Windows by copying setup files from the USB to the HDD? If so, how do I go about doing that? I can get to the command prompt when I boot from my USB. What do I do after that?
  4. Would changing the install from Ultimate to Professional or Home or something help? I only have the key to Ultimate, but I can install it without the key for a little while if that would fix the problem.

Any other suggestions?

I do not have any technical background. Whatever I've tried, I've done it after reading it online, so I would really appreciate a detailed explanation. I've read other entries on here as well, but they haven't helped solve my problem.

share|improve this question
    
"I have checked the Ram and there is no problem whatsoever with the hardware" There's more hardware than RAM in the world. ;) Did you try different media (depending on how you're installing: different disk, different optical drive, and/or different USB stick)? How about drive checks? How long did you test the memory for (anything less than several hours to multiple days is NOT a good RAM check). –  techie007 Jun 22 '12 at 18:21
    
also, have you seen this: forums.bit-tech.net/showthread.php?t=177488 –  techie007 Jun 22 '12 at 18:23
    
@techie007 Yes I'm aware there is more hardware than just RAM. Anyway, yes I've tried it with multiple different USBs that work fine. The USB installed Windows fine on my computer where I'm writing this. I left the memory check running all night long. And yes, I've tried the simple solution that link provided. Another thing, like I said in the post, I don't have a working CD/DVD drive. I could try copying installation files from my USB to the HDD, but I don't know how to go about it after I get to the command prompt from the system recovery area. –  Nicolás Carlo Jun 22 '12 at 18:35
    
How are you installing from USB? With the Microsoft USB/DVD iso tool? Is the 7% stalling happening at the initial "loading files" phase, or are you able to go through the config and then it's failing on the "full" install? If you can config, have you tried deleting the partition and reformatting? Would you consider putting something like Ubuntu on it temporarily as a test that nothing else is wrong with the system? (It's a pretty quick install.) –  techturtle Jun 22 '12 at 19:53
    
@techturtle Yes I used the Microsoft's USB/DVD tool to create the USB. The 7% thing is after I format the HDD, and select it to install the OS. Then it says "That's all we need right now" and the second step there is "Extracting Files" or something, that's where it crashes around 7% and tells me "Windows can't install the file..." with the error code I posted above. It seems like its a recurring problem with DELL m1330 if USB is in use, that's why I'm wondering how I could copy files to the HDD and try from there. –  Nicolás Carlo Jun 22 '12 at 19:57
show 4 more comments

1 Answer

up vote 2 down vote accepted

http://www.instructables.com/id/Install-Windows-7-without-USB-or-DVD-without-upgra/ has step-by-step instructions on copying Windows setup files to the hard drive, making it bootable, and installing Windows 7. From the site:

How to CLEAN Install Windows 7 directly from Hard drive – NO DVD or USB needed!!

For example, you have a netbook or desktop that you want to install Windows 7 onto, but can’t use DVD or USB for whatever reason (or don't want to, like me). This method will allow you to boot and install Windows directly from the hard drive. This guide involves plugging the hard drive into another working computer, preparing the hard drive, placing it back in the system, and installing Windows as usual.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.