Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running a .COM file on a MS-DOS 6.22 boot USB drive When I run it on my laptop the program works fine but when I run it on my desktop I get error 40 not enough extended memory.

When I go to the memory tab in GUI I try to switch none to auto, but I get the error "This file might be read-only". It's not read-only, when I put it on my desktop I change the settings and the new settings are in a .pif I can't run .pif in MS-DOs so I need to

  1. Change the .exe not create a .pif.
  2. Change the amount of extended memory all files have on my MS-DOS.

On my laptop there is no memory tab, the only real difference is my laptop is x64. Thanks for helping but I think teh x64 bit has nothing to do with it I dont eve nthink iits in 64 bit mode because Im using a boot USB. What i need to is listed above, thanks for helping.

share|improve this question

closed as not a real question by Canadian Luke, KronoS, Mokubai, Tom Wijsman, Ƭᴇcʜιᴇ007 Jun 23 '12 at 5:14

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
You need to explain what is different between your Desktop and your Laptop. You also need to clarify what your question is exactly there is a great deal of noise. –  Ramhound Jun 22 '12 at 19:56
    
Possible duplicate: superuser.com/questions/333103/… –  Canadian Luke Jun 22 '12 at 22:01
    
What are the specifications of your computer? Do you have enough memory? –  Tom Wijsman Jun 22 '12 at 22:45
    
Yeh I need to run my .EXE files in a sepcial environment –  Jake Inc. Jun 22 '12 at 23:40
    
Wait, what‽ A 16-bit .com file won’t run on your 32-bit desktop, but does run on your 64-bit laptop? Are you sure you didn’t get that backwards? o.O –  Synetech Sep 1 '12 at 20:54

2 Answers 2

up vote 1 down vote accepted

Remember, you cannot run 16-bit DOS applications on any Windows x64 architecture[1] without running a 32-bit emulation of Windows/DOS[2] (i.e. running Windows XP Mode on top of Windows 7 Professional x64)

share|improve this answer
    
You may want to link him to some kind of primer or tutorial because he actually said I think teh [sic] x64 bit has nothing to do with it I dont [sic] eve [sic] nthink iits in 64 bit mode because Im [sic] using a boot USB. [sic sic sick] :-| –  Synetech Sep 1 '12 at 20:55
    
@synetech if the question gets reopened, sure –  Canadian Luke Sep 2 '12 at 4:41
    
You can’t edit? That’s odd; I didn’t think editing an answer to a closed question required higher rep. –  Synetech Sep 4 '12 at 0:36
    
@synetech It doesn't. I just won't edit my answer if the question needs fixing –  Canadian Luke Sep 4 '12 at 1:12

Your best option can be using Virtual PC. It is available inside Windows as a component. Create the virtual PC with 32 bit architecture and you will be able to run legacy application and move it as a file across machines.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.