Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have done the following in an attempt to host a Rails 3.2.3 application using Apache 2.2.21 and Passenger 3.0.13:

  1. Installed gem Passenger
  2. rvmsudo passenger-install-apache2-module
  3. Added website info in /etc/apache2/extra/httpd-vhosts.conf
  4. Added line to /etc/hosts (not sure if this was needed or not; not mentioned in Passenger documentation
  5. Uncommented out the line in /etc/apache2/httpd.conf to Include /etc/apache2/extra/httpd-vhosts.conf
  6. Restarted Apache

When I try to pull up my website the following displays:

Index of /

    Name    Last modified   Size    Description

Apache/2.2.21 (Unix) mod_ssl/2.2.21 OpenSSL/0.9.8r DAV/2 PHP/5.3.10 with Suhosin-Patch Phusion_Passenger/3.0.13 Server at lightbesandbox2.com Port 443

Here is /etc/hosts entry for the website:

127.0.0.1   www.lightbesandbox2.com

Here is my /etc/apache2/extra/httpd-vhosts.conf entry for the website:

NameVirtualHost *:80

<VirtualHost *:80>
  ServerName www.lightbesandbox2.com
  ServerAlias lightbesandbox2.com
  PassengerAppRoot /Users/server1/Sites/iktusnetlive_RoR/ 
  DocumentRoot /Users/server1/Sites/iktusnetlive_RoR/public    
  <Directory /Users/server1/Sites/iktusnetlive_RoR/public>
    AllowOverride all
    Options -MultiViews
  </Directory>
</VirtualHost>

When I do rvmsudo passenger-status I get the following output:

----------- General information -----------
max      = 6
count    = 1
active   = 0
inactive = 1
Waiting on global queue: 0

----------- Application groups -----------
/Users/server1/Sites/iktusnetlive_RoR/:
  App root: /Users/server1/Sites/iktusnetlive_RoR/
  * PID: 8140    Sessions: 0    Processed: 2       Uptime: 20m 51s

None of my assets are in the public folder in my Rails app. I have written an application using the template presented in Michael Hartl's Ruby on Rails Tutorial. The home page is in /app/views/static_pages/home.html.erb. I decided to copy an index.html file in the public folder to see if it would display. It displayed as I had hoped..

Is there a way to get Passenger to find my assets without me having to rewrite my application?

Any help would be appreciated.

share|improve this question

1 Answer 1

I ended up dropping this for a bit but was able to start again after using a newer version of Phusion Passenger. I have used version 3.0.18 on my development server and 3.0.19 on my production server. I had some OS corruption in my security settings. After doing a clean install of my server software I was able to start over with the installation of Phusion Passenger and get it working just fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.