Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had this same problem with another Linksys router using stock firmware and recently replaced it with a WRT54GL using the latest version of Tomato. The connection runs perfectly when the router is first turns on, but over the course of the day (or sometimes several days) the speed over wireless-G degrades dramatically (from 18+ Mbps when the router first starts to a few hundred Kbps later on).

This can't be related to anything other than the router because it happens on everything in the house that's wireless -- the Wii, the iPod Touch, the netbook, and Apple laptop, you name it. The connection slows to a crawl eventually, and one reboot later everything's running at top speed again.

Tomato is a stock installation. I had bumped the transmit power to 70 for a few days but dialed it back to the default 42 when this problem cropped up so I could eliminate that as a factor.

Is there something I'm missing? QOS settings or other Tomato configuration errors? Is there any long-term fix, or would I be better off investigating other options like powerline Ethernet (running cable isn't an option right now)?

Thanks!

share|improve this question
add comment

3 Answers

Try changing the TCP and UDP connection timeouts to lower values (the setting can be found here). Try halving the values that are in there already. Also, disable QoS and see if the problem persists.

One alternative may be to use an alternative Tomato distribution, like hardc0re's mod.

share|improve this answer
add comment

I think I found the problem. I ran a channel scan using Tomato and it reported that a previously undetected router was running on the same channel as mine. Switched it to a clear channel and have had a full day without any of the throughput degradation I'd experienced before.

Many thanks to Breakthrough for the suggestions!

share|improve this answer
    
Changing channels seems to have worked for me too. When I moved in to my apartment, I picked an empty channel, but the wireless environment changed over time, and I discovered that my selected channel was now highly populated. Changing to another channel seems to have worked. –  Ryan Thompson Jan 31 '10 at 0:23
add comment

Thank you for the tip. I had the same problem with my WRT54GL. I changed the channel and now is the wifi speed a lot better than before.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.