Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

SSH Agent Forwarding stopped working for me.

Any ideas as to what might be going on? I'm attaching my logs below:

Connecting to the server: http://goo.gl/4xxz9

Connecting to github on server: http://goo.gl/61Wpa

Thanks!

--

Additional Info:

I've been using the ssh forwarding guide on github to troubleshoot - https://help.github.com/articles/using-ssh-agent-forwarding

echo "$SSH_AUTH_SOCK" works both on the server and my local machine, and I have checked both .ssh/config and /etc/ssh_config - they're set up correctly.

However, the forwarding doesn't seem to be actually working - "ssh -T [email protected]" works locally, but not if I run it on the server.

Everything's working fine for a colleague - when he runs the "ssh -T [email protected]" command on the server, he authenticates with github successfully.

share|improve this question
    
It would be helpful to include debug logs from client and server sides of the connection. You can generate client logs by adding -vvv to your command. –  Don Simon Jun 22 '12 at 22:15
    
@DonSimon, I've just added log/debug traces. –  stringo0 Jun 26 '12 at 14:19
    
Does public key work locally? From the first log, it looks like your identification file doesn't exist, and it's trying all possible default key names, but finding none of them. "Trying private key: /home/launchdevs/.ssh/id_rsa debug3: no such identity: /home/launchdevs/.ssh/id_rsa debug1: Trying private key: /home/launchdevs/.ssh/id_dsa debug3: no such identity: /home/launchdevs/.ssh/id_dsa debug1: Trying private key: /home/launchdevs/.ssh/id_ecdsa debug3: no such identity: /home/launchdevs/.ssh/id_ecdsa debug2: we did not send a packet, disable method" –  Don Simon Jun 26 '12 at 16:50
    
Yes - I'm able to pull/push code from my local computer, connect to the server via ssh, etc. I'm assuming this is what you meant? –  stringo0 Jun 29 '12 at 22:23
add comment

closed as too localized by Factor Mystic, BBlake, Canadian Luke, Nifle, Diogo Sep 15 '12 at 23:25

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

up vote 1 down vote accepted

I recreated my ssh keys, this time with a passphrase, and everything works great.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.