Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So what I have is a file from a staff computer that I believe is an access file b/c its called .mdb, however it does not open! I even tried to follow the repair steps (create a new file and use the "compact and repair" tool. and all I keep getting is "unrecognized file format *.mdb" (replace the * with the filename). I am not even sure it is an access file. I have tried using Office 2007 and office 2010 but neither work. Is there a way to fix this that is not on the Microsoft website? Or to determine whether this is actually an access file and not some other file with the extension renamed?

Any help would be appricated, thanks.

share|improve this question

migrated from stackoverflow.com Jun 23 '12 at 3:10

This question came from our site for professional and enthusiast programmers.

add comment

3 Answers

this may help: File Identifier, or you can use a program like XVI32 to look at the file directly - sometimes there are clues to the filetype within the first few characters

share|improve this answer
add comment

View the file with a Hex Editor (here's a free one). A Microsoft Access 2003 or earlier file will start with the text "Standard Jet DB". "Jet" is the name of the data engine that reads/writes Access data - stands for "Joint Engine Technology". A 2007 or newer Access file will start with "Standard ACE DB". ACE = Access Connectivity Engine.

share|improve this answer
add comment

I'd try to make use of trid, which makes an informed guess of what a file is, and the file command in linux, which compares it against magic numbers. Trid also has a online version and a filetype index

I think older versions should be backwards compatible with newer versions, but seeing what the staff's computer has would be a smart bet.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.