Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to simulate keyboard combinations.

I am able to do this on Windows with AutoHotKey.

Is there an equivalent app for Ubuntu?

share|improve this question
1  
to answer this question correctly: what is the DE (desktop environment, aka 'kde', 'gnome', 'xfce' etc) you are using? if you answer that, one would check out how to bind keys to certain actions. – akira Sep 20 '09 at 6:54
2  
I think it's safe to say that Ubuntu implies gnome unless otherwise noted. – itsadok Oct 6 '09 at 6:20
    
I'm using Gnome. – lipton Oct 29 '09 at 20:40
up vote 4 down vote accepted

The links in nik's answer are a bit old but still pretty useful, although there have been quite a few advancements since then. There is IronAHK currently available which is a complete rewrite of AutoHotkey which works under .NET as well as Mono, allowing it to have cross-platform compatibility. It's also free and fully open source.

share|improve this answer
    
+1, this is nice. – nik Sep 21 '09 at 6:45
1  
Very promising, but the project doesn't seem to have made any releases yet. I don't see any option other than to fetch and compile the source yourself. Has anyone used it? – nagul Sep 24 '09 at 22:51

Brainstorm Ubuntu: Idea #588: AutoHotkey for Ubuntu (automation, hotkeys) has some notes.
You may also want to look at AutoKey - the (totally rewritten) text expansion and hotkey utility.

Finally, this older Idea #163: Sytem-wide shortcut configuration refers many discussions on the subject. Like akira comments, your desktop environment may already support easy key bindings.

share|improve this answer

I believe you should be able to do this with xbindkeys+xvkbd. That is, install xbindkeys, xbindkeys-config, xvkbd. Configure xbindkeys to call xvkbd on Windows keys, i.e. in ~/.xbindkeysrc, add:

"sleep 0.2 && /usr/bin/xvkbd -text "\A\t""
    c:115
"sleep 0.2 && /usr/bin/xvkbd -text "\A\t""
    c:116

If this works, add xbindkeys to System > Preferences > Sessions > Startup Programs and maybe disable default assignments in ~/.xbindkeysrc

share|improve this answer

there is a port in progress ahklinux

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .