Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I start a game, initially it runs smoothly, but after a couple of minutes, the performance gradually decreases to the point of being unplayable (1-2 FPS). The sound also starts to lag at this point.

This does not happen every time I start my PC, usually exiting the game, rebooting, then starting the game again solves the problem, and I can play with perfect FPS for as long as I want. I could not find any deterministic reason when this happens and when doesn't. It happens in every game I tried (SWTOR, Diablo 3, Skyrim), and not even games, but simple applications like a browser or the Control Panel can get unusably slow. This is a brand new PC I bought three months ago, and this problem occurs since the first day I've been using it.

Could you provide any advice how to further diagnose the problem? I tried to reinstall Windows, and tried different video card drivers, but it did not help. It would be important to know whether this is a hardware or software problem, because I can use the warranty if it is a hardware issue. (I did not want to return the PC yet, because I can't reproduce the issue deterministically.)

Spec of the pc:

  • Motherboard: ASROCK H61M-HVS
  • CPU: INTEL Core i3-2120 3.30GHz 1155 BOX
  • Memory: KINGMAX 4096MB DDR3 1333MHz KIT
  • Video card: GIGABYTE GV-R685OC-1GD HD6850 1GB GDDR5 PCIE
  • HDD: SEAGATE 500GB Barracuda 7200rpm 16MB SATA3 ST500DM002

I am using Windows 7 64 bit.

Thanks a lot in advance!

UPDATE: I checked the CPU temperature with Core Temp, and it was about 50 °C.

However, today I started my PC, and started a game, and the FPS slowed down after a couple of minutes, so I checked the temperature again, and it was 102 °C, I guess that's extremely high. So I rebooted, then the temp slowly decreased to around 50 °C, then I started the game again, and played without any problem for an hour, and the temperature was still 50 °C.

Do you have any idea what can cause this symptom? Maybe the CPU fan does not start when I start the PC for the first time but starts after a reboot?

share|improve this question
2  
Whats your CPU temperature? My intel processor starts running slower if it gets too hot. It seems like similar symptoms since FPS starts fine and ends up horrible. –  Chris Harris Jun 23 '12 at 8:36
    
Hmm. What's the easiest way to determine the temperature? –  Márk Vincze Jun 23 '12 at 9:04
1  
Often, you can check in the BIOS under something like "PC Status/Health". Or you could download "Core Temp" which is pretty easy to use. –  Chris Harris Jun 23 '12 at 9:08
1  
You can use Speedfan also –  HackToHell Jun 23 '12 at 10:43
    
When it gets slow what does the Windows 7 Resource Monitor report? Which (if any) resources are busy? If you've reinstalled Windows and it didn't help, then you have a valid hardware warranty claim. Take it back. –  Ƭᴇcʜιᴇ007 Jun 23 '12 at 14:08

2 Answers 2

up vote 1 down vote accepted

As you determined, your system is getting too hot (105°C is high) and so the motherboard is throttling the CPU to prevent it from overheating further (the motherboard injects a variable number of HALT instructions into the bus which allow the CPU to do nothing for a while and thus cool down).

You can use the ASRock UEFI Setup Utility (page 34 of the manual) to view the current thermal-management settings (page 42). If you disable the throttling, then the system will instead just shut down altogether when the CPU overheats (page 10).

You will want to make sure to apply thermal grease and that the fan/heatsink is affixed securely to the CPU (page 18). You can also ensure that there is adequate airflow in the case, but with temperatures that high, you will need to address the CPU directly first since poor airflow is usually not enough to get it that high; the CPU-to-heatsink heat transfer is more likely the problem.

share|improve this answer
    
Thanks for the answer. The strange thing is though that when I start the PC, the CPU either gets hot and slow after 5-10 minutes, or it works perfectly smoothly (and stays at normal temp) for as long as I use it. So I suspect the CPU fan sometimes starts and sometimes doesn't. –  Márk Vincze Jun 25 '12 at 6:08
    
Well then you have your answer. The CPU fan is faulty. I bet that if you give leave the case open and look at it, sometimes it will spin and other times not, but if you give it a push, it will start. This is a common failure that these types of brushless fans experience. Like I said, the airflow in the case is a secondary issue and the main problem is at the CPU (paste, heatsink, fan, etc.), so you will want to try changing it. –  Synetech Jun 25 '12 at 18:34
    
Yes, today I got the time to check it, and the fan does not spin, it sometimes jiggle a little. So I'm going to take it back to the shop. Thanks for the help! –  Márk Vincze Jun 25 '12 at 18:54

I see your motherboard has an intel built-in HD 2000 video card, check your game is running on your pcie GFX instead because the intel would be a lot slower than your HD6850.

You can try the GPU Observer widget, if you are running two monitors keep an eye on the GFX card temperature via the widget while your playing a game and see if it goes up (it could go up to 90°c which is an acceptable limit), you can also run the game windowed for the same purpose.

Else, try memtest. Maybe you have defective ram.

Edit: I forgot, AtiTool will be able to search defects on your HD6850.

share|improve this answer
    
Thanks for the answer. Initially the game runs perfectly smooth, and only starts to slow down after a couple of minutes, so I don't think it uses the built-in card. I'm going to try to run the tools you mentioned. –  Márk Vincze Jun 23 '12 at 11:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.