Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
“Open With” dialog ignores my selection

I am using Windows 7. I am using Processing 2.06a and want to start .PDE files with the processing.exe file. Processing does not have install files (like Eclipse, or any other portable software) so you can place it anywhere. I placed it in the Program Files folder however.

If I rightclick on a .PDE file,

click "Open with...",

click "Browse...",

look for the "processing.exe" file,

click "OK" (in the browse dialog)

and click "OK" (in the open with dialog)

it does not open Processing, but it opens Adobe Reader (presumably since it is the first item in the list).

share|improve this question

marked as duplicate by Synetech, Kaze, Renan, Nifle, Factor Mystic Jul 23 '12 at 1:32

This question was marked as an exact duplicate of an existing question.

  1. After you browse and select processing.exe from the Browse dialog, please ensure that processing.exe is also selected in the Open With dialog.

  2. Make sure that the following option is checked - Always use the selected program to open this kind of file

You have most likely selected Adobe Acrobat reader and made it the default program. You can right click your PDE files and look at the section labeled Opens with to identify the default program. To change the default program, click on change and click on browse and follow steps 1 & 2.


share|improve this answer
thanks, this is indeed the normal procedure I am familiar with. However, after selecting the EXE it doesn't appear in the Open With Dialog... so I can't select it there. It's neither under "Recommended Programs" or "Other Programs" – joon Jun 23 '12 at 13:33
A quick search seems to indicate that processing.exe is not registered properly. You're required to make a registry edit. The fix is available here… – R.. Jun 23 '12 at 14:21

Not the answer you're looking for? Browse other questions tagged .