Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an external hard drive that was used as a Windows partition before, but now I want to use it for storage instead. I have added it to my Windows 7 machine, but I am not allowed to write or delete serveral of the files and folders on the disk. I get the error message access is denied, even though I am administrator. I have tried to log in to the Administrator account with Net user administrator /active:yes, changed ownership and disabled UAC, but nothing helps. I still get access is denied and can not delete anything.

share|improve this question
add comment

4 Answers

up vote 2 down vote accepted

You can use unlocker to delete the windows directory. Just install it and it will appear int the right click context menu.

enter image description here

enter image description here

You can also use boot delete which has the ability to delete the files at the boot time.

share|improve this answer
add comment

I often get access denied errors because the file is in use by a process. I don't know why the error isn't more helpful.

If that's not it, you can try recursively making all the files on the drive writeable with the attrib command:

ATTRIB -R -S C:\ /S /D

(Replace C: with the correct drive, of course)

share|improve this answer
add comment

If you are the Administrator and you can't delete the files on drive, that means the drive is "Read-Only". meaning you don't have write access to the drive. You can verify this by right clicking on the drive and choosing Properties > Security > Advanced > Edit. In that tab you can change the settings and allow "read/write" for the administrator or specific users.

share|improve this answer
    
I get access is denied for a lot of files when I change from read-only. –  user1049697 Jun 23 '12 at 16:23
add comment

You don't have access to that files/folder. You should go to Properties -> Security -> Advanced and change to owner to your user (check subfolders if needed)

share|improve this answer
    
I still get access denied, even if I set myself to owner. –  user1049697 Jun 23 '12 at 18:15
1  
try to boot from a linux live cd and delete the files –  Remus Rigo Jun 24 '12 at 9:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.