Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Lenovo w520, after i bought it i took away old hhd (no longer with me) and replaced it with intel ssd, it worked perfectly for 1 year or so, today my system fr0ze and after waiting for some time i didi hard reset - it wasn't able to boot anymore at all, i do not see any messages from windows ever, it only loads Intel boot utility that suggests to pick one of 3 devices to boot, it has my hdd there but nothing happens.

/I dont have recovery tools from lenovo since i moved to another country, i got win 7 cd from a friend (came with his laptop) abd if in bios i have AHCI - it doesnt see my ssd, if compatible mode - it sees it but format not available, partition creation gives b\me 8007045 error. I tried diskpart, in compatible mode it sees my disk but doesnt do recover or clean all, also win 7 disk tools dont do anything if i try to do boot fix...

I am ok with erasing it but i seem not to be able too, i jus tneed the machine to wpork asap, all my files are on external drives so i dont care about formatting. please help! I am given a very old machine by a friend so i am able to browse internet... it is under XP...

share|improve this question

1 Answer 1

0x8007045d = ERROR_IO_DEVICE

May be used to indicate that the device has stopped responding (hung). The device may need to be manually reset.

Source

In compatibility/IDE mode you shouldn't need any drivers for Windows to use it, and if you don't have working drivers, you just won't see it at all.

So that not working for you even though you can (kind of) see the drive, plus the above error (with no hardware changes), then it sounds like the drive has failed.

Before completely giving up, here are a couple things you can try (but I wouldn't hold your breath):

  • Get the proper AHCI driver(s) from Lenovo and use that with the Windows 7 disk (while set to AHCI mode in the BIOS).
  • Try it in another computer.
  • Try accessing it from a LiveCD-style OS.
share|improve this answer
    
I am trying Live CD usb bootable thing, lenovo provides linux diagnostic tool 500mb but it gives only 2 tests, it sees my ssd, but it passes the test only partially. I am in Italy, Milan, and here it is very bad with computers or parts, plus i dont really want to throw it away yet, hope there could be something. –  Ori Jun 23 '12 at 21:55
    
So it also fails Lenovo's own bootable HDD diagnostics? If so, then it sounds BROKEN, GIVE UP. ;) According to Levono, there's no Milan repair depots, but there are 10 in Rome. I'm sure there's several computer stores in the Milan area that can take a look at it and do some testing for you. –  Ƭᴇcʜιᴇ007 Jun 23 '12 at 22:05
    
well it says it doesn't support some diagnostic types also under linux bootable usb it sees only 8mb intel partition, it is intel ssd and i bough tit separately so i am not sure why it should be tested with lenovo utilities... –  Ori Jun 23 '12 at 22:21
    
True point. I took "passes the test only partially" to mean that it failed some of the tests. I still think it's just busted. ;) Good luck! Perhaps other's will have some ideas. –  Ƭᴇcʜιᴇ007 Jun 23 '12 at 22:49
    
I found that it is called Intel ssd 8 mb bug, there is a firmware fix but i need to do secure erase coz without it doesn't install properly, and i am not sure how to do it i am running virtual windows vista –  Ori Jun 24 '12 at 17:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.